Buscar este blog

Cargando...

jueves, 10 de diciembre de 2009

TALLER 5.




1. escriba un programa que facilite calcular la retención en la fuente a descontar al empleado según el salario del empleado. para ello se ingresa cédula del empleado, salario básico. la retención se debe calcular de acuerdo a los siguientes rangos y aplicando los porcentajes indicados:

�� $ 2,250,000.oo a 2,500,000.oo 1.5 %

�� $ 2,501,000.oo a 3,000,000.oo 2.0 %

�� $ 3,000,000.oo a 3,500,000.oo 2.5 %

�� $ 3,501,000.oo en adelante 3.0 %

1.
qué piden? calcular cual es el descuento de la retención en la fuente según el salario del empleado.
qué me dan? número de cédula, salario básico y el porcentaje descuento según el salario.
cómo lo hago? Comparo el valor del salario del empleado con los porcentajes indicados, dependiendo el salario y su rango multiplico el valor del salario por el valor del descuento.

2.
algoritmo
inicio
conocer el número de cédula
conocer el valor del salario básico
conocer el valor del salario y su respectivo descuento en porcentaje
calcular el valor del descuento
mostrar resultados
fin

3.
constantes
des1= 0,015, des2= 0,02, des3=0,025, des4=0,03
variables
nuced, : cadena
salb, desc: real

4.
programa
cons des1= 0,015, des2= 0,02, des3=0,025, des4=0,03
var
nuced, : cadena
salb, desc: real
inicio
nuced=0, salb=0, desc=0;
escriba"ingrese el número de cédula:”, lea nuced
escriba”ingrese el valor del salario básico:”, lea salb
si salb >= 2.250.000 y salb <= 2.500.000 entonces
des = salb * des1
finsi
sino
si salb >= 2.501.000 y salb <=3.000.000 entonces
des = salb * des2
finsi
sino
si sa_b >= 3.000.000. y salb <= 3.500.000 entonces
des = salb * des3
finsi
sino
si salb >= 3.501.000 entonces
des = salb * des4
finsi
escriba “numero de cedula es”; “nuced”;
escriba “el valor del descuento es”; desc;
fin

2. elabore un programa para liquidar el valor a pagar a un floricultor por su producción. por cada compra se ingresa los siguientes datos: cantidad de cajas, variedad de flor (1= rosas, 2= pompones, 3= claveles). para ello se tiene establecidas según la variedad las siguientes tarifas en us$ por caja:

-rosas a us$ 3.5.oo

- pompones a us$ 4.85.oo

-claveles a us$ 3.8.oo

1
qué piden? liquidar el valor total a pagar a un floricultor dependiendo de si producción y teniendo en cuenta el calor por caja y valor de cuenta y el tipo de flor.
qué me dan? la cantidad de cajas, la variedad de flores y el valor por caja en dólar.
cómo lo hago? comparo la variedad de flores y sus respectivas tarifas por caja, luego dependiendo de la variedad de las flores multiplico la cantidad de cajas por el valor en dólar.

2
algoritmo
inicio
conocer la variedad de flores
conocer la cantidad de cajas
conocer la calidad de flor escogido
calcular el valor por caja
mostrar el valor a pagar
fin

3
Const
cjros = 3.5
cj pom = 4.85
cj cla = 3.8

var
cancaj: entero
varflo: cadena
tp: real

4
programa
const cj_ros= 3.5, cj_pom = 4.85, cj_cla= 3.8

var
cancaj: entero
varflo: cadena
totpa: real

inicio
var_f = 0; can_cla= 0; tp = 0;
escriba “1 rosas”;
escriba “2 pompones”;
escriba “3 claveles”
escriba “ingrese el tipo de flor”; lea varflo;
escriba “ingrese la cantidad de cajas”; lea cancaj;
si varflo = 1 entonces
totpa = cancaj * cj_ros
finsi
sino
si varflo = 2 entonces
totpa = can_cla * cj_pom
finsi
sino
si varflo= 3
totpa = cancaj * cj_cla
finsi
fin
escriba “valor a pagar del producido es”; tp;
fin

3. en un hipermercado se ha establecido un sistema de descuentos de acuerdo a la forma de pago. 1 efectivo y 2 tarjeta de crédito. para las compras en efectivo (1) superiores a $ 80.000 se descuenta un 7% del valor de la compra. para las compras con tarjeta de crédito superiores a $ 250.000 se descuenta un 4% y para las superiores a $280.000 un 8% de descuento. escriba un programa que permita calcular y muestre el valor de la compra, descuento y valor a pagar por el cliente.

1
qué piden? establecer el valor de la compra, el valor del descuento y el valor a pagar por cliente.
qué me dan? la variedad de pago, el total de la compra y el valor del descuento.
cómo lo hago? solicitando la forma de pago, comparo el valor de la compra con su respectivo descuento, y luego multiplico el valor de la compra por el del descuento y del valor de la compra resto el valor del descuento.

2
algoritmo
inicio
1. conocer la variedad de pago
2. conocer el total de la compra
3. variedad forma de pago para calcular el descuento
4. calcular la cantidad del descuento
5. mostrar el total a pagar
fin

3
const
val des1 = 0.07
val des2 = 0.04
val des3= 0,08
var
for pág.: cadena
valcom, des, valpa: real

4
programa
const
val des1 = 0.07
val des2 = 0.04
val des3= 0,08
var for p: cadena
valcom, des, valpa: real
inicio
val des1 = 0 val des2 = 0 val des3= 0

escriba “efectivo = 1”;
escriba “tarjeta de credito = 2”;
escriba “digite la forma de pago”; lea fp;
escriba “digite el valor de la compra”; lea valcom;
si fp = '1' entonces
si valcom >= 80.000 entonces
des = valcom * val des1
finsi
sino
si fp = “2” entonces
si valcom >= 250.000 y valcom <= 280.000 entonces
des = valcom *val des 2
finsi
sino
si valcom > 280.000 entonces
des = valcom * val des 3
finsi
val_p = valcom - des
escriba “valor de la compra es”; valcom;
escriba “el valor del descuento es” des;
escriba “el valor a pagar es”, valpa;
fin

4. en un banco se ha creado un sistema de incentivos para los clientes que compran con tarjeta de crédito. para ello de acuerdo al valor total de las compras del mes establece la siguiente asignación de puntos: compras entre $80.000 y $200.000, 100 puntos; hasta $400.000, 200 puntos; menos de $700.000, 350 puntos; de 700.000 en adelante 450 puntos. escriba un programa que muestre un bono con el valor de las compras y los puntos asignados al cliente.

1
qué piden? la cantidad y el valor de la compra y los puntos asignados al cliente en un bono.
qué me dan? el valor de la compra con los respectivos puntos asignados.
cómo lo hago? determinando el valor de la compra y retribuir los puntos asignados a esta.

2
algoritmo
inicio
1. conocer el equivalente de la compra
2. retribuir la cantidad de puntos según sea la compra
3. mostrar el total de puntos
fin

3
const
pt1 = 100
pt2 = 200
pt3 = 350
pt4 = 450

var
valcom real
cant_p: entero

4
programa

const

pt1 = 100
pt2 = 200
pt3 = 350
pt4 = 450

var
valcom real
cantpun: entero

inicio
valcom = 0; cantpun = 0;

escriba “digite el valor de las compras”; lea valcom;
si valcom >= 80.000 y valcom <= 200.000 entonces
cantpun = pt1
finsi
sino
si valcom > 200.000 y valcom <= 400.000 entonces
canpun = pt2
finsi
sino
si valcom > 400.000 y <= 700.000 entonces
canpun = pt3
finsi
sino
si valcom > 700.000 entonces
canpun = pt4
finsi
escriba “valor de la compra es”; valcom;
escriba “la cantidad de puntos es” cantpun;
fin

5. escriba un programa que permita asignar la calificación conceptual para la nota de un estudiante en un colegio de secundaria. la calificación numérica de notas esta entre 0 y 10. los conceptos son: para notas entre 0 y 3.99 deficiente, entre 4.0 y 6.99 insuficiente, notas hasta 7.99 aceptable, hasta 8.99 sobresaliente y hasta 10 excelente. se debe mostrar un boletín con el código del estudiante, nombre,
1
Que me pide? Asignar la calificaron del estudiante
Que me dan? Conceptos para las notas

2
algoritmo
inicio
1. conocer el código, el nombre y el apellido del estudiante.
2. conocer la calificación obtenida por el estudiante
3. evaluar el puntaje de la calificación
4. asignar la calificación final
5. mostrar los datos del estudiante y su calificación final
fin

3
const
nt1 = “deficiente”
nt2 = “insuficiente”
nt3 = “aceptable”
nt4 = “sobresaliente”
nt5 = “excelente”

var
notaee real
cal, cod, nom_e cadena

4
programa:
const
nt1 = “deficiente”
nt2 = “insuficiente”
nt3 = “aceptable”
nt4 = “sobresaliente”
nt5 = “excelente”

var
notaes real
calif, cod, nomes cadena
inicio

calif = “0”; cod= “0”; nomes = “0”; notes = 0;

escriba “digite el código del estudiante”; lea cod;
escriba “digite el nombre del estudiante”; lea nomes;
escriba “digite la nota del estudiante”; lea notaes;
si not_e >= 0 y notaes <= 3,99 entonces
caifl = nt1
finsi
sino
si notaes >=4 y notaes < 6.99 entonces
calif = nt2
finsi
sino
si notaes >6.99 y notaes <= 7,99 entonces
calif = nt3
finsi
sino
si notaes >= 7.99 y notaes < = 8.99 entonces
caifl= nt4
finsi
sino
si notaes > 8.99 y notaes <=10
calif = nt5
finsi
escriba “el código del estudiante es:”; cod;
escriba “el nombre del estudiante:”; nomes;
escriba “nota del estudiante:”; notaes;
escriba “calificación porcentual:”; calif”
fin

6. El ICETEX otorgara créditos para educación semestralmente. Para ello se debe tener en cuenta el estrato y el tipo de educación a realizar. Los estratos socioeconómicos van del 1 al 6, el tipo de educación es 1:Superior, 2: Especialización, 3:Maestría. Los créditos equivalen a un porcentaje del valor del semestre de acuerdo al estrato así: Estrato 1 el 90%, 2 el 75%, 3 el 55%, 4 y 5 el 40%; por el tipo de educación se asignara adicionalmente para el 2 el 5%, 3 el 10%. El programa debe mostrar un reporte que contenga el valor del semestre, valor del crédito y el valor a pagar por el estudiante.

1
Qué piden? Liquidar el valor del credito y el valor a pagar de acuerdo al estrato y tipo de educacion
Qué me dan? Valor del semestre, tipo de educacion,estrato
Cómo lo hago? Calculando el valor del credito

2
Algoritmo
Inicio
1 conocer datos de entrada
2 validar estrato y tipo de educacion para calcular el credito
3 mostrar resultados
Fin

3
constantes
C1=0.90
C2=0.75
C3=0.55
C4=0.40
C5=0.05
C6=0.10
Variables
Vsm,vdc,vp real
Est,tpe entero

4

inicio
Escriba” ingrese el valor del semestre” lea vsm
Escriba” digite el estrato socioeconomico” lea est
Escriba” ingrese el tipo de educación en el que desea ingresar” lea tpe
Si est=6 entonces
Vdc=0
Sino
Si est=4 o est=5 entonces
Si tpe=2 entonces
Vdc=vsm*(c4+c5)
Sino
Si tpe=3 entonces
Vdc=vsm*(c4+c6)
Sino
Vdc=vsm*c4
Fin si
Fin si
Sino
Si est=3 entonces
Si tpe=2 entonces
Vdc=vsm*(c3+c5)
Sino
Si tpe=3 entonces
Vdc=vsm*(c3+c6)
Sino
Vdc=vsm*c3
Fin si
Fin si
Sino
Si est=2 entonces
Si tpe=2 entonces
Vdc=vsm*(c2+c5)
Sino
Si tpe=3 entonces
Vdc=vsm*(c2+c6)
Sino
Vdc=vsm*c2
Fin si
Fin si
Sino
Si est=1 entonces
Si tpe=2 entonces
Vdc=vsm*(c1+c5)
Sino
Si tpe=3 entonces
Vdc=vsm*(c1+c6)
Sino
Vdc=vsm*c1
Fin si
Fin si
Fin si
Vp`=vsm-vdc
Escriba”el valor del semestre es”,vsm
Escriba”el valor del credito es”,vdc
Escriba”el valor a pagar es”,vp
Fin

7. La empresa de renta de vehiculos Flying Rent cobra de acuerdo a la cantidad de kilómetros recorridos por el arrendatario, descontándolo de un monto dejado al recibir el vehículo, que puede ser 1:Moto o 2:Auto, 3 Lanchas y Yates. Para ello tiene la siguiente tabla para liquidar el cobro: Para vehículos tipo 1 menos de 50 Kms $ 30,000, hasta 100 kms $ 60,000, mas de 100 Kms 60,000 mas un incremento de $ 500 pesos por km adicional; para vehículos tipo 2 menos de 70 Kms $ 50,000, entre 71 y 110 Kms $ 90,000, hasta 200 Kms $ 150,000, mas de 200 Kms 150,000 mas $ 3000 por Km adicional. Vehículos tipo 3 $105,000 cada 10 Millas(1 Milla náutica equivale a 1.85 Kms) Escriba un programa que liquide el valor que debe pagar una persona por el alquiler teniendo en cuenta la base dejada indicando si le sobra dinero o cuanto le falta.

1
Qué piden? Liquidar el valor del alquiler de cierto tipo de vehiculos y decir si le sobra o le falta dinero
Qué me dan? Tipo de vehiculo, cantidad de km recorridos y monto dejado
Cómo lo hago? Realizando la comparacion correspondiente y calculando el valor a pagar

2
Algoritmo
Inicio
1 conocer datos de entrada
2 validar tipo de vehiculo y cantidad de km recorridos para realizar la operación correspondiente
3 mostrar resultados
Fin

3
constantes
K1=30000 k3=50000 k6=105000
K2=60000 k4=90000 fcm=1.85
Ick1=500 k5=150000 ick2=3000
Variables
Tvh, ck entero
Md,vp,fs real

4
inicio
escriba”ingrese el tipo de vehiculo” lea tvh
escriba”ingrese la cantidad de kilómetros recorridos” lea ck
escriba”ingrese la cantidad del monto dejado” lea md
si tvh=1 entonces
si ck<50 entonces
vp=md-k1
sino
si ck<=100 entonces
vp=md-k2
sino
si ck>100 entonces
vp=md-(k2+((ck-100)*ick1))
fin si
fin si
fin si
sino
si tv=2 entonces
si ck<70 entonces
vp=md-k3
sino
si ck>=71 y ck<=110 entonces
vp=md-k4
sino
si ck>=200 entonces
vp=md-k5
sino
si ck>200 entonces
vp= md-(k5+((ck-200)*ick2))
fin si
fin si
fin si
fin si
sino
si tv=3 entonces
mll=ck*fcm
vp=md-((mlldiv10)*k6)
fin si
fin
escriba”el valor a pargar es”,vp
si vp>0 entonces
fs=(md-vp)*-1
escriba “falta dinero”,fs
sino
fs=md-vp
escriba “la cantidad sobrante es”,fs
fin si
fin

8. En una librería se esta promocionando la compra de libros según el tipo de literatura. Los tipos de literatura 1 Ciencia ficción, 2 Científica. Se tiene la siguiente tabla de descuentos según la cantidad de libros comprados, de 3 a 5 un 5% literatura tipo 1, 7% literatura tipo 2 del valor total de la compra, de 6 a 10 un 10% literatura tipo 1, 12% literatura tipo 2 del valor total de la compra, más de 10 libros un 15% literatura tipo 1, 18% literatura tipo 2 del valor total de la compra Escriba un programa que muestre como resultado una factura que contenga: Cantidad de libros comprados, valor total de la compra, valor a descontar y valor a pagar.

1
Qué piden? Calcular el valor a pagar de libros dependiendo de la cantidad y tipo de libro
Qué me dan? Cantidad de libros, valor de los libros y tipo de lectura
Cómo lo hago?calculando el descuento y despues se resta del valor de la compra

2
Algoritmo

Inicio
1 conocer datos de entrada
2 validar nota numerica para asignar la nota conceptual correspondiente
3 mostrar resultados
Fin

3
constantes
Fd1=0.05 cd1=0.07
Fd2=0.10 cd2=0.12
Fd3=0.15 cd3=0.18
Variables
Vlb,vcom,des,vtp real
Cl,tl entero

4
inicio
Escriba “ingrese la cantidad de libros ” lea cl
Escriba “ingrese el valor de los libros” lea vlb
Escriba “ingrese el tipo de lectura” lea tl
Vcom=vlb*cl
Si tl=1 entonces
Si cl>=3 y cl<=5 entonces
Des=vcom-(vcom*fd1)
Sino
Si cl>=6y cl<=10 entonces
Des=vcom-(vcom*fd2)
Sino
Si cl>10 entonces
Des=vcom-(vcom*fd3)
Fin si
Fin si
Fin si
Sino
Si tl=2 entonces
Si cl>=3 y cl<=5 entonces
Des=vcom-(vcomxcd1)
Sino
Si cl>=6 y cl<=10 entonces
Des=vcom-(-vcom*cd2)
Sino
Si cl>entonces
Des=vcom-(vcom*fd3)
Fin si
Fin si
Fin si
Fin si
Fin si
Vtp=vcomp-des
Escriba “la cantidad de libros es”,cl
Escriba “el valor de la compra es”,vcom
Escriba “el valor del descuento es”,des
Escriba “el total a pagar es”,vtp
Fin

9. En el Banco Anglo se requiere un programa para la asignación de cupos de crédito de acuerdo al valor ahorrado por sus Clientes. Para ello se establece la siguiente tabla: Ahorros superiores a $ 2.000.000 y hasta $ 4.000.000, tienen cupo de tres veces la cantidad ahorrada; ahorros superiores a $ 4.000.000 y hasta 10.000.000, tienen un cupo de cinco veces la cantidad ahorrada; ahorros superiores a 10.000.000 y hasta 30.000.000, tienen un cupo de 8 veces la cantidad ahorrada; ahorros superiores a 30.000.000, se les asigna 10 veces la cantidad ahorrada. Debe producir un extracto que muestre por cada ahorrador: número de cuenta, valor ahorrado y cupo de crédito asignado.

1
Qué piden? Calcular el cupo de credito de una persona
Qué me dan? Numero de la cuenta y valor ahorrado
Cómo lo hago? Multiplicando el valor ahorrado por la cantidad indicada

2
Algoritmo
Inicio
1 conocer datos de entrada
2 validar cantidad ahorrada para realizar la operación correspondiente
3 mostrar resultados
Fin

3
Var
Nc cadena
Vah,vc real

4

Inicio
Escriba “ingrese el numero de la cuenta” lea nc
Escriba “ingrese el valor ahorrado” lea vah
Si vah>2000000 y vah<=4000000 entonceds
Vc=vah*3
Sino
Si vah>4000000 y vah<=10000000 entonces
Vc=vah*5
Sino
Si vah>10000000 y vah<=30000000
Vc=vah*10
Fin si
Fin si
Fin si
Escriba “el numero de la cuenta es”,nc
Escriba”el valor ahorrado es”,vah
Escriba”el el cupo de credito es”,vc
Fin



10. la distribuidora de revistas laser x requiere de un programa que le facilite liquidar las bonificaciones por ventas de revistas a sus vendedores. las revistas están clasificadas así: 1: deportes, 2: negocios y finanzas, 3: hogar, 4: mujer. para la liquidación de la bonificación se debe aplicar la tabla así: para tipo de revista 1 con cantidades superiores a 1000 unidades tiene un 50% de un smlv, por debajo pero no menor a 200 10% de un smlv; para revistas tipo 2 mas de 1500 obtendrán un 60% de un smlv, no menos de 1000 25% de un smlv; revistas tipo 3 y 4 mas de 600 unidades 40% de un smlv, no menos de 200 un 20% del smlv. un smlv (salario mínimo legal vigente) equivale al valor fijado para el año actual. se debe producir un desprendible de pago con los siguientes datos: cédula, nombre, cantidad de revistas vendidas, valor bonificación.

1
qué piden? liquidar el valor de la bonificacion de acuerdo a la cantidad de revistas vendidas
qué me dan? tipo de revistas, cantidad de revistas, nombre, salario
cómo lo hago? el valor de la bonificacion es igual al salario por el porcentaje

2
algoritmo
inicio
1 conocer datos de entrada
2 validar tipo de revistas y cantidad vendida para calcular la bonificacion
3 mostrar resultados
fin


3
rede=0.50 rene=0.60 refem=0.40
rede2=0.10 rene2=0.25 refem2=0.20
variables
cc,nope cadena
sami real
cr,tire entero

4.
Programa
const
rede=0.50 rene=0.60 rfm=0.40
rede2=0.10 rene2=0.25 refem2=0.20
variables
cc,nope cadena
sami real
cr,tire entero
inicio
escriba “ingrese la cedula” lea cc
escriba “ingrese el nombre de la persona” lea nope
escriba “ingrese la cantidad de revistas” lea cr
escriba “ingrese el tipo de revistas” lea tire
escriba “ingrese el valor del salario” lea sami

si tr=1 entonces
si cr>1000 entonces
vabo=sm*rede
sino
si cr<1000 y cr>=200 entonces
vb=sm*rede2
fin si
fin si
sino
si tire=2 entonces
si cr>1500
vabo=sami*rene
sino
si cr<=1500y cr>=100 entonces
vabo=sami*rene2
fin si
fin si
fin si
sino
si tire=3 0n tire=4 entonces
si cr>600 entonces
vabp=sami*refem
sino
si cr<=600 y cr>=200
vabo=same*refem2
fin si
fin si
fin si
fin si
escriba “numero de identificacion”,cc
escriba “nombre” , nope
escriba “la cantidad de revistas vendidas es” , cr
escriba “el valor de la bonificacion es” ,vabo
fin

GLOSARIO




Esta todas aquellas palabras necesaria para logica:



Algoritmo: es la forma como se plantea u organiza la realización o proceso de un programa.

Bicondicional: es un operador que opera sobre dos valores de verdad, típicamente los valores de verdad de dos proposiciones, devolviendo el valor de verdad verdadero cuando ambas proposiciones son verdaderas, o cuando ambas son falsas.

Condicional: es un operador que opera sobre dos valores de verdad, típicamente los valores de verdad de dos proposiciones, devolviendo el valor de verdad falso sólo cuando la primera proposición es verdadera y la segunda falsa, y verdadero en cualquier otro caso.

Constante: todo valor que no tiene cambios en la ejecución del programa
Conjunción: es un operador que opera sobre dos valores de verdad, típicamente los valores de verdad de dos proposiciones, devolviendo el valor de verdad

Cuerpo de ciclo: (c) conjunto de acciones a ejecutar una o mas veces

Declaración: Es la aclaración que se hace en un programa para indicarle al computador que datos se utilizaran.

Disyunción: es un operador que opera sobre dos valores de verdad, típicamente los valores de verdad de dos proposiciones, devolviendo el valor de verdad verdadero cuando una de las proposiciones es verdadera, o cuando ambas lo son, y falso cuando ambas son falsas.

Diagrama De Flujo: es una representación gráfica de un algoritmo o de una parte del mismo.

Evaluación de proposiciones: consiste en obtener el grado de verdad o falsedad de la expresión, que se representa por valores 1 o 0.

Estructura: es una forma de escribir programas de ordenador (programación de computadora) de forma clara. Para ello utiliza únicamente tres estructuras: secuencia, selección e iteración; siendo innecesario el uso de la instrucción o instrucciones de transferencia incondicional

Estructura selectiva simple: esta compuesta de una proposición que es evaluada y si el resultado de la evaluación es verdadero, entonces ejecuta la acción o acciones indicadas con la palabra indicada entonces

Estructura selectiva compuesta
Esta compuesta de una proposición que es evaluada y si el resultado de la evaluación es verdadero, entonces ejecuta la acción o acciones indicadas por la palabra entonces, y si es falso , de lo contrario se utilizara la palabra sino

Estructura selectiva anidada: La estructura selectiva es anidada cuando dentro de alguna acción de ésta, se encuentra otra estructura selectiva y la(s) acción(es) de esta puede contener otra selectiva y esta otra más; es decir cuando después de una decisión se debe tomar otra, después otra y así sucesivamente.

Identificador: es un conjunto de caracteres alfanuméricos de cualquier longitud que sirve para identificar las entidades del programa (clases, funciones, variables, tipos compuestos, Etc.)

Lenguaje de programación: es el conjunto de instrucciones ordenadas de forma lógica y secuencial, escritas en un lenguaje de programación de computadores con el fin de resolver un problema o una necesidad especifica.

Lógica de programación: consiste en la aplicación del corpus de conocimiento sobre lógica para el diseño de lenguajes de programación; no debe confundirse con la disciplina de la lógica computacional.
La programación lógica comprende dos paradigmas de programación: la programación declarativa y la programación funcional

Negación: La negación es un operador que opera sobre un único valor de verdad, típicamente el valor de verdad de una proposición, devolviendo el valor de verdad verdadero si la proposición es falsa, y falso si la proposición es verdadera.

Operador: son expresiones que nos permiten manipular los datos que les pasamos, cada uno de los datos que se le pasa a un operador se llama operando, y según el número de operandos de que disponga un operador estaremos hablando de un operador unario (un operando), binario (dos operandos), ternario...

Proposición: es una oración con valor referencial o informativo, de la cual se puede predicar su veracidad o falsedad, es decir, que puede ser falsa o verdadera pero no ambas a la vez.

Programa: es el conjunto de instrucciones ordenadas de forma lógica y secuencial, escritas en un lenguaje de programación de computadores con el fin de resolver un problema o una necesidad especifica.

Proceso: conjunto de acciones

Seudo lenguaje: es la representación de la solución a un problema utilizando una estructura y lenguaje similar al de un lenguaje de programación

Tabla de verdad: es una tabla que despliega el valor de verdad de una proposición compuesta, para cada combinación de valores de verdad que se pueda asignar a sus componentes. verdadero cuando ambas proposiciones son verdaderas, y falso en cualquier otro caso.

Variable todo valor que cambie o se pueda modificar en al ejecución d l programa
los tipos de operadores se clasifican así: aritméticos, relacionales y lógicos

Valor limite:(n) el número máximo de iteraciones a realizar

TALLER 4.



TALLER 4.



ESTRUCTURAS CONDICIONALES





Hasta el momento en este curso, se ha trabajado con estructuras secuénciales, las que permiten crear soluciones a problemas que no representan mayor dificultad, porque no se tiene que tomar decisiones o escoger uno u otro conjunto de instrucciones a ejecutar.
Las estructuras condicionales dentro de las técnicas de programación estructurada, permiten crear soluciones que representan el reto de tomar decisiones, para ejecutar instrucciones diferentes dependiendo del resultado obtenido de evaluar las expresiones condicionales para los casos propuestos.
1. Estructuras condicionales
1.1 Simples
1.2 Alternas
1.3 Anidadas

1. Estructuras condicionales
Estas representan la facilidad de incorporar alternativas de solución a las necesidades del medio o problema a resolver, aplicando en ello cualquiera de los tipos de estructuras condicionales.

1.1 Simple
La estructura condicional simple, permite ejecutar un conjunto de instrucciones, solo cuando al evaluar la expresión condicional se obtiene como valor de verdad uno (1) o verdadero. El siguiente es el esquema que representa esta estructura:
Si (Condición) entonces

Fin_Si

1.2 Alternas
La estructura condicional alterna a diferencia de la simple, permite bifurcar en la ejecución de una u otra alternativa de instrucciones. El siguiente es el esquema que representa esta estructura:
Si (Condición) entonces

si_no

Fin_Si


TALLER 4

5.1= Suponga que en la Universidad del Tolima se concede descuento del 50% del valor de la matricula, a los estudiantes de estrato 1. La matricula equivale a un (1) salario mínimo mensual legal vigente (461,500.00) . Escriba un programa.
análisis calcular valor matricula según el estrato del estudiante
Que me piden: calcular el valor de la matricula con el descuento que le ofrece la universidad a los estudiantes de estratos bajos.
Que me dan: el valor de la matricula y el descuento.
Como lo hago: verificando si el estudiante es de estrato 1
Si es estrato 1 entonces val_mat = sal_mini * des
Si es otro estrato entonces val_matri = equi_mat
Algoritmo: matricula
Inicio
1 conocer los datos
2 calcular: matricula para estrato 1 y otros estratos
3 mostrar: resultado
algoritmo_fin
definición de variables y constantes
Variables: estrato1, equi_mat”cadena”

Constantes: des”cadena”
Sal_mini”cadena”
Entrada:
sal_mini “salario minimo” cadena Equi_mat”valor de la matricula para otros estratos” real
Des”descuento de la matricula para estrato 1” cadena
Proceso:
val_mat”valor a pagar para estrato 1”real
Val_matri”valor a pagar para otros estratos” real
programa matricula
Var: estrato1,”cadena”
equi_mat, val_mat, val_matri”real”
Cons: des, sal_mini”cadena”
Inicio
1. Escriba”matricula es igual al salario mínimo” lea sal_mini
2. Escriba”valor de la matricula para otros estratos”
Lea equi_mat
3. Escriba”descuento para matricula de estrato 1” lea des
4. si estrato1 = “sal_mini” entonces
Val_mat = sal_mini * des
Fin_si
5. si val_matri = “equi_mat” entonces
Val_matri = equi_mat
Fin_si
6. escriba “valor a pagar para estrato 1”, val_mat
7. escriba”valor a pagar para otros estratos”, val_matri

5.2= Suponga que en la Universidad del Tolima se concede descuento del 50% del valor de la matricula, a los estudiantes de estrato 1 y que su promedio académico en el semestre anterior halla sido superior o igual a 4-5. La matricula equivale a un (1) salario mínimo mensual legal vigente (461,500.00) . Escriba un programa.
Análisis del problema:
Liquidar le valor de la matricula a los estudiantes antiguos que tengan un promedio de 4-5.

Que me piden?
Liquidar el valor de la matricula.

Que me dan?
Valor de la matricula, descuento para estudiantes con promedio de 4-5 valor salario mínimo.

Como lo hago?
conociendo estrato y nota académico que debe ser 4-5, multiplico el valor de la matricula por el 50 y lo divido por 100


Algoritmo_ promedio de matricula
Inicio
1. Conocer el estrato del estudiante.
2. Conocer el promedio.
3. Conocer el valor de la matricula.
3. Conocer el descuento para los estudiantes de estrato 1con promedio igual 4-5.
4. Calcular el valor de dicho descuento multiplicando el valor de la matricula por el 50 y dividirlo por 100.
5. Mostrar el resultado.
Fin

Declaración de constantes y variables:

Constantes:
matricula = 461,500.00

variables:
estrato entero
promedio real
total mat real

algoritmo _ matricula promedio
inicio
estrato = 0; promedio = 0; total mat = 0;
escriba “digite el estrato al que pertenezca”; lea estrato;
escriba “digite promedio académico”; lea promedio
si
estrato = 1 ^ promedio >= 4.5
entonces
total mat = (matricula*50)/100;
escriba “valor total matricula”; total mat;
sino
escriba “valor total matricula”; matricula
fin si

5.3= En la Universidad del Tolima se concede descuentos para el pago de matricula considerando lo siguiente: a estudiantes de estrato 1 o 2 y con promedio de notas no inferior a 3.8 el 50%, estudiantes de estrato 3 el 30% si su promedio de notas es superior a 4.2. La matricula equivale a un (1) salario mínimo mensual legal vigente (461,500.00) . Escriba un programa.

análisis hacer un programa que me el valor de descuento según sus notas y estratos Que me piden: calcular el valor del descuento para los estudiantes dependiendo del estrato y del promedio.

Que me dan: el valor del descuento dependiendo del estrato y el promedio académico.

Como lo hago: verificando el estrato del estudiante y el promedio
Si es estrt1_2 y prom3_8 entonces
v_mtcl = slr_mnm * dct
Si es estrt3 y prom4_2 entonces
vl_mtcl = slr_mnm * des

Algoritmo: descuento y promedio
Conocer: datos
Calcular: valor matricula dependiendo del estrato y el promedio académico.
Mostrar: resultado

Definición de variables y constantes
Constantes:
estrt1_2, estrt3, dct, des “cadena”
Slr_mnm, v_mtrcl, vl_mtcl “real”
Variable:
prom3_8, prom4_2 “real”
Entrada:
slr_mnm ”la matricula equivale a un salario mínimo”real
dsct”descuento por estrato 1y2 y promedio académico”
cadena
des_c”descuento por estrato 3 y promedio académico” cadena
estrt1_2” estrato del estudiante 1 y 2” cadena
estrato3” clase de descuento para estrato 3 ”cadena
prom3_8”promedio academico para estrato 1 y 2”real
prom4_2”promedio academico para estrato 3” real

Proceso:
v_mtrcl” valor matricula estrato 1 y 2 y promedio mayor de 3.8 “ real
vl_mtcl” valor matricula estrato 3 y promedio mayor de 4.2” real

Programa: descuento y promedio

Cons: estrt1_2, estrt3, dct, des, Slr_mnm
Var : prom3_8, prom4_2

Inicio

1. escriba”la matricula equivale a un salario mínimo”Lea slr_mnm
2. Escriba”descuento por estrato 1y2 y promedio académico”Lea dct
3. escriba”descuento por estrato 3 y promedio académico” Lea des
4. escriba” estrato del estudiante”Lea estrt1_2
5. escriba” clase de descuento para estrato 3” Lea estrato3
6. escrba”promedio academico para estrato 1 y 2”lea prom3_8
7. escriba”promedio academico para estrato 3”lea prom4_2
8. si estrt1_2 = “prom3_8” entonces
V_mtcl = slr_mnm * dct
Fin_si
9. si estrt3 = “prom4_2 “ entonces
Vl_mtcl = slr_mnm * des
Fin_si
10. escriba” valor matricula estrato 1 y 2 y promedio mayor de 3.8 “, v_mtcl
11. escriba” valor matricula estrato 3 y promedio mayor de 4.2” , vl_mtcl
fin-programa


5.4= El almacén 3 X 1 solicita se le elabore un programa que facilite calcular el valor de una venta a partir del valor unitario, cantidad, tipo de producto (1. No grabado, 2. Grabado). Se debe tener en cuenta que el IVA se aplica según el tipo de articulo si es grabado se aplica el 16% de lo contrario no tiene IVA. (IVA porcentaje para calcular el impuesto de valor agregado a un producto, que se adiciona al valor unitario)
análisis del problema:
mirar valor del iva de un producto por sul tipo y valor unitario.

que me piden?
calcular el valor de una venta.

que me dan?
valor del iva y el tipo de producto.

como lo hago?
saber el tipo de producto y el valor del iva correspondiente, si es de tipo 2, multiplico el valor unitario por 16 y lo divido por 100, el resultado lo multiplico por la cantidad. si es de tipo 1 multiplico el valor de la unidad por la cantidad.
tproduct =<1^>2
(vunit*16)/100)cant
vunit*cant


algoritmo _ venta iva
inicio
1. ingresar valor del producto.
2. ingresar cantidad de producto.
3. ingresar tipo de producto.
4. conocer producto tipo de producto.
tproduct =<1^>2
5. calcular producto si es tipo 2
((vunit*16)/100)*cant
6. calcular producto si es tipo 1
vunit*cant
7. mostrar valor de la venta
fin

declaración de constantes y variables

constante iva% 16

variables:
vunit =real; cant = entero; tproduc = real; total = real;

algoritmo_ venta cantidad
inicio
vunit=0; cant=0; tproduc=0l; total=0;
escriba “digite valor unitario del producto”; lea vunit;
escriba “digite cantidad de producto”; lea cant;
escriba “digite tipo d producto”; lea tproduc;
si
tproduc = 2
entonces
total = ((vunit*16)/100)*cant
escriba “total a pagar”; total;
sino
tproduc = 1
entonces
total = vunit*cant
escriba “total a pagar”; total
sino
tproduct <1^>2
entonces
escriba “el tipo de producto es desconocido”;
fin si

1. Escriba un algoritmo que calcule el interés obtenido por una suma de dinero, para ello se debe ingresar por teclado la cantidad de dinero (mayor a cero), la tasa de interés (se debe validar que siempre sea mayor que 0), el tiempo en días (debe ser mayor a 0).
ANALISIS: Elaborar un programa que calcule el interés obtenido por una suma de dinero mayor a cero, con una tasa de interés mayor que cero y con unos días de intereses mayores que cero.
¿Qué me piden? Calcular el valor del interés obtenido por una suma de dinero mayor que cero.
¿Qué me dan? El valor de la suma de dinero, la tasa de interés diario y los días de intereses.
¿Cómo lo hago? Multiplicando la suma de dinero por la tasa de interés y el resultado lo multiplico a la cantidad de días de intereses.
Eje:
SDDI= 500’000
TDID: 10%
CDDI: 300
VIDI: ¿? (Valor Interés Diario)
VIOB: ¿? (Valor Interés Obtenido)
VIDI = SDDI*TDID
VIOB = VIDI*CDDI
VIDI = 500’000*10%
VIOB = 50’000*300= 15’000,000
Algoritmo CalcII
Inicio
Conocer el valor de la suma de dinero.
Conocer el valor de la tasa de interés.
Conocer el número de días de intereses.
Calcular el valor del interés obtenido de la suma de dinero.
Mostrar resultados
Fin
Definición y Declaración de Variables y Constantes
Variables: Entrada: SDDI, Real
TDID, Real
CDDI, Real

Proceso: VIDI, Real
VIOB, Real
Programa CalcII
VAR: Real: SDDI, TDID, CDDI, VIDI, VIOB
Inicio
VIDI= 0 VIOB=0
Escriba: “VALOR DE LA SUMA DE DINERO”, Lea SDDI
Escriba: “VALOR DE LA TASA DE INTERÉS DIARIO”, Lea TDID
Escriba: “CANTIDAD DE DÍAS DE INTERESES”, Lea CDDI
VIDI = SDDI*TDID
VIOB = VIDI*CDDI
Escriba: “CALCULO DEL VALOR DEL INTERÉS DIARIO”, VIDI
Escriba: “CALCULO DEL VALOR DEL INTERÉS OBTENIDO”, VIOB
Fin

2. Se ingresa por teclado los datos A, B y C, determine cuál es el mayor.
ANALISIS: Elaborar un programa que calcule cual de los datos ingresados (A, B, C) es el mayor.
¿Qué me piden? Determinar cuál de los datos ingresados es el mayo.
¿Qué me dan? Los datos ingresados A, B, C.
¿Cómo lo hago? Dando cualquier valor numérico a los datos ingresados.
Otra forma seria:
Si (A>B) y (A>C) entonces
Escriba “El Numero mayor es A”
Sino
Si (B>A) y (B>C) entonces
Escriba “El Numero mayor es B”
Sino
Escriba “El Numero mayor es C”
Finsi
Algoritmo Mayor
Inicio
Conocer el valor de A.
Conocer el valor de B.
Conocer el valor de C.
Mostrar el resultado.
Fin_Algoritmo
Definición y declaración de variables:
Entrada: VA, Real
VB, Real
VC, Real
Proceso: VM, Real
4. Programa Mayor
VAR
VA: Real, VB: Real, VC: Real, VM: Real
Inicio
Escriba “Dame un valor para A”; Lea A
Escriba “Dame un valor para B”; Lea B
Escriba “Dame un valor para C”; Lea C
Si (A>B) y (A>C) entonces
Escriba “El Numero mayor es A”
Sino
Si (B>A) y (B>C) entonces
Escriba “El Numero mayor es B”
Sino
Escriba “El Numero mayor es C”
Finsi
Fin
3. Se ingresa por teclado los datos A, B y C, determine cuál es el mayor y cual el menor.
ANALISIS: Elaborar un programa que calcule cual de los datos ingresados (A, B, C) es el mayor y cuál es el menor.
¿Qué me piden? Determinar cuál de los datos ingresados es el mayor y cuál es el menor.
¿Qué me dan? Los datos ingresados A, B, C.
¿Cómo lo hago? Dando cualquier valor numérico a los datos ingresados.
Otra forma seria:
Si (A>B) y (A>C) entonces
Escriba “El Numero mayor es A”
Sino
Si (B>A) y (B>C) entonces
Escriba “El Numero mayor es B”
Sino
Escriba “El Numero mayor es C”
Sino
Si (A
Escriba “El Numero menor es A”
Sino
Si (B
Escriba “El Numero menor es B”
Sino
Escriba “El Numero menor es C”
Finsi
Algoritmo Mayor_Menor
Inicio
Conocer el valor de A.
Conocer el valor de B.
Conocer el valor de C.
Mostrar el resultado.
Fin_Algoritmo

Definición y declaración de variables:
Entrada: VDA, Real
VDB, Real
VDC, Real
Proceso: VMA, Real
VME, Real
Programa Mayor_Menor
VAR
VA: Real, VB: Real, VC: Real, VMA: Real, VME: Real
Inicio
Escriba “Dame un valor para A”; Lea A
Escriba “Dame un valor para B”; Lea B
Escriba “Dame un valor para C”; Lea C
Si (A>B) y (A>C) entonces
Escriba “El Numero mayor es A”
Sino
Si (B>A) y (B>C) entonces
Escriba “El Numero mayor es B”
Sino
Escriba “El Numero mayor es C”
Sino
Si (A
Escriba “El Numero menor es A”
Sino
Si (B
Escriba “El Numero menor es B”
Sino
Escriba “El Numero menor es C”
Finsi
Fin

4. Se ingresa por teclado los datos A, B y C, determine cuál es el mayor, el menor y el del medio.
ANALISIS: Elaborar un programa que calcule cual de los datos ingresados (A, B, C) es el mayor, cuál es el menor y cuál es el del medio.
¿Qué me piden? Determinar cuál de los datos ingresados es el mayor, cual es el del medio y cuál es el menor.
¿Qué me dan? Los datos ingresados A, B, C.
¿Cómo lo hago? Dando cualquier valor numérico a los datos ingresados.
Otra forma seria:
Si (A>B) y (A>C) entonces
Escriba “El Numero mayor es A”
Sino
Si (B>A) y (B>C) entonces
Escriba “El Numero mayor es B”
Sino
Escriba “El Numero mayor es C”
Sino
Si (A
Escriba “El Numero menor es A”
Sino
Si (B
Escriba “El Numero menor es B”
Sino
Escriba “El Numero menor es C”
Si (A>B) y (B>C) entonces
Escriba “El Numero del medio es B”
Sino
Si (B>A) y (A>C) entonces
Escriba “El Numero del medio es A”
Sino
Escriba “El Numero del medio es C”
Finsi
Algoritmo Mayor_Medio_Menor
Inicio
Conocer el valor de A.
Conocer el valor de B.
Conocer el valor de C.
Mostrar el resultado.
Fin_Algoritmo

Definición y declaración de variables:
Entrada: VDA, Real
VDB, Real
VDC, Real
Proceso: VMAY, Real
VMED, Real
VMEN, Real
Programa Mayor_Medio_Menor
VAR
VA: Real, VB: Real, VC: Real, VMAY: Real, VMED: Real, VMEN: Real
Inicio
Escriba “Dame un valor para A”; Lea A
Escriba “Dame un valor para B”; Lea B
Escriba “Dame un valor para C”; Lea C
Si (A>B) y (A>C) entonces
Escriba “El Numero mayor es A”
Sino
Si (B>A) y (B>C) entonces
Escriba “El Numero mayor es B”
Sino
Escriba “El Numero mayor es C”
Sino
Si (A
Escriba “El Numero menor es A”
Sino
Si (B
Escriba “El Numero menor es B”
Sino
Escriba “El Numero menor es C”
Finsi
Si (A>B) y (B>C) entonces
Escriba “El Numero del medio es B”
Sino
Si (B>A) y (A>C) entonces
Escriba “El Numero del medio es A”
Sino
Escriba “El Numero del medio es C”
Finsi
Fin

5. Escriba un programa que acepte la entrada de un número entero y se determine si es par o impar.
ANALISIS: Elaborar un programa que acepte números enteros y determine si son par o impar.
¿Qué me piden? Determinar si el dato entero es par o impar.
¿Qué me dan? Un número entero.
¿Cómo lo hago? Dividiendo el numero entero en dos y si el residuo que obtenemos es cero entonces podemos decir que es par de lo contrario es impar.
RSD=0 de ENT/2
Otra forma seria:
Si Numero Entero y Residuo= “0 (cero)” Entonces
Escriba “Numero Par”
Sino
Escriba “Número Impar”
Finsi
Algoritmo Par_Impar
Inicio
Conocer el número entero.
Calcular el residuo de la división entre el entero y el dos.
Mostrar el resultado
Fin_Algoritmo
Definición y declaración de variables:
Entrada: Entero, ENT, Entero
Proceso: Residuo, RSD, Real
Tipo de entero, TDE [2], Cadena
Programa Par_Impar
VAR
ENT: Entero, RSD: Real, TDE, Cadena [2]
Inicio
Escriba “Un numero entero”, Lea ENT
Si ENT y RSD= “0” entonces
Escriba “Numero Par”
Sino
Escriba “Número Impar”
Finsi
Fin
6.Calcular la edad de una persona a partir de los datos de la fecha de nacimiento.
1. análisis: programa que calcule la edad de una persona a partir de la fecha de nacimiento
Que me piden? calcule la edad de una persona a partir de la fecha de nacimiento
Que me dan? fecha de nacimiento
Como lo hago?
1. con la siguiente fórmula:
EDAD=año actual ¬¬- año de nacimiento de la persona

2.ALGORITMO
Conocer los datos de entrada fecha de nacimiento
Calcular edad
Mostrar resultado
Fin
3. Definición de variables y constantes
de entrada
fecha de nacimiento real
4.Seudo lenguaje
Var
Fecha de nacimiento
Inicio
Escriba” año actual:” lea fecha actual
Escriba” año de nacimiento:” lea año de nacimiento
EDAD=año actual- año de nacimiento
Mostrar “resultado edad:” edad
Fin
7.Calcular la raíz cuadrada para un numero positivo dado por teclado. Mostrar el resultado obtenido.
1. análisis: programa que calcule la raíz cuadrada de un numero positivo
Que me piden? calcular la raíz cuadrada de un numero positivo
Que me dan? raíz cuadrada
Como lo hago?
1. asignando un numero positivo y lo elevó al cudrado sacar raíz cuadrada.
Raíz=n.p^2=raíz numero positivo
2.ALGORITMO
Conocer los datos de entrada numero positivo
Calcular raíz cuadrada
Mostrar resultado
Fin
3.Definición de variables y constantes
de entrada
numero positivo real
de proceso
raíz cuadrada real
4.Seudo lenguaje
Var
Numero positivo
Inicio
Escriba” numero positivo ^2:” lea n. positivo ^2
Raíz=n.p^2=raíz n.p
Mostrar “resultado raíz del numero positivo:” raíz de n.p
Fin
8.Elabore un programa que permita realizar una suma o resta de dos números ingresados por teclado, según se obtenga respuesta a la petición de tipo de operación, en un mensaje al que debe responder S o N.
1. Análisis: programa que permita realizar una suma o resta y que envié un mensaje de que operación y un mensaje que debe responder si o no
Que piden?. Programa que permita realizar una operación (suma o resta) y que envié un mensaje de que operación si suma o resta si o no
Que me dan? operaciones (suma o resta)y dos números
Como lo hago?
Evaluando que tipo de operación si suma o resta va a ejecutar con los dos números entonces se muestra un mensaje con la petición del tipo de operación que debe responder si o no
Otra forma seria:
Si suma o resta entonces
Si suma entonces
Escriba “ suma “
Sino
Escriba “ resta”
Finsi
Si
Escriba “si suma o no suma”
Sino
Escriba” resta”
Finsi
2. Algoritmo
inicio
1. Conocer el datos de entrada suma o resta y los dos números
2. calcular que tipo de operación se va a utilizar con los dos números si suma o resta y mostrar un mensaje si o no
3. Mostrar resultado
Fin
3. Definición y declaración de variables:
Entrada: dos números real
Proceso: suma y resta real
4. Programa
var
dos números, suma o resta
inicio
Escriba ‘ dos numeros : ‘ Lea dos n
//Aquí inicia el proceso de suma o resta
Si suma o resta entonces
Si suma entonces
Escriba “ suma “
Sino
Escriba “ resta”
Finsi
Si
Escriba “si suma o no suma”
Sino
Escriba” resta”
Finsi
10.Elabore un programa para validar la entrada del dato sexo. Los valores permitidos son M o F, minúsculas o mayúsculas. Según sea el valor se debe mostrar el Letrero Masculino o Femenino, si no es ninguna de estas dos letras debe mostrar un mensaje de Equivocación.
1. Análisis del problema: Escribir un programa para determinar si los valores indicados para el dato genero o sexo son correctos o no.
Que piden? Validar la entrada del dato sexo mostrando si es Masculino o Femenino en caso contrario error.
Que me dan? Género o sexo.
Como lo hago?
Evaluando o validando el valor del dato sexo para saber si es un valor aceptable entonces se muestra el letrero Masculino o Femenino según sea el caso; de no ser así se muestra un mensaje de error.
2. Algoritmo Genero
Inicio
1 Conocer el dato sexo
2 Evaluar el valor del dato sexo para saber si es un valor aceptable entonces mostrar el letrero Masculino o Femenino según sea el caso; de no ser así se muestra un mensaje de error
Fin_Algoritmo
3. Definición y declaración de variables:
Entrada : sexo : Cadena
Proceso :
4. Programa Genero
VAR
Sexo : Cadena
Inicio
Escriba ‘ Genero o Sexo [M: Masculino, F: Femenino] : ‘ Lea sexo
//Aquí inicia el proceso de validación del valor del dato sexo
Si sexo = “F” o sexo = “f” o sexo = “M” o sexo = “m” entonces
Si sexo = “F” o sexo = “f” entonces
Escriba “ Genero Femenino “
Sino
Escriba “ Genero Masculino”
Finsi
Sino
Escriba “No es un valor aceptado para Genero o Sexo”
Finsi



11.
Un Almacén por departamentos requiere un programa para validar la entrada de los códigos de departamento, son ocho, numerados de 1 a 8. Al validar cada código se debe mostrar el nombre del departamento: 1 Cristalería, 2 Ferretería, 3 Ropa, 4 Rancho y Licores, 5 Granos, 6 Carnes y Lácteos, 7 Verduras, 8 Deportes. Si se ingresa un valor errado se debe mostrar un mensaje de advertencia.

Análisis del problema:
entrada de 8 códigos y que cada uno de ellos represente un departamento de un almacén.

Que me piden
Validar los códigos de los diferentes departamentos en un almacén.


Que me dan
Cada uno de los códigos

Como lo hago
Se designa el valor que toma cada uno de los números, que representa los diferentes departamentos que componen el almacén,
Algoritmo _ Almacén codigo
Inicio
1. Digite un numero.
2. Si el número digitado anteriormente es menor y mayor que 8.
3. Muestre “el numero ingresado no es un departamento del almacén”.
4. Si digita 1 entonces escriba “departamento de cristalería”.
5. Si digita 2 entonces escriba “departamento de ferretería”
6. Si digita 3 entonces escriba “departamento de ropa”
7. Si digita 4 entonces escriba “departamento de rancho y licores”
8. Si digita 5 entonces muestre “departamento de granos”
9. Si digita 6 entonces muestre “departamento de carnes y verduras”
10. Si digita 7 entonces muestre “departamento de verduras”
11. Si digita 8 entonces muestre “departamento de deportes”
12. Mostrar resultados.
Fin


Declaración de constantes y variables:

Variables:
OPC ENTERO

Algoritmo _ Almacén
Inicio
OPC = 0;
Escriba “Digite el código del departamento”; Lea OPC;
Si
OPC <0^>8
Entonces
Escriba “No es un departamento del almacén”;
sino
opc = 1
entonces
escriba “departamento de cristalería”;
sino
opc = 2
entonces
escriba “departamento de ferretería”;
sino
opc = 3
entonces
escriba “departamento de ropa”;
sino
opc = 4
entonces
escriba “departamento de rancho y licores”;
sino
opc = 5
entonces
escriba “departamento de granos”;
sino
opc = 6
entonces
escriba “departamento de carnes y verduras”;
sino
opc = 7
entonces
escriba “departamento de verduras”;
sino
escriba “departamento de deportes”;
fin si
fin si
fin si
fin si
fin si
fin si
fin si
fin si
12.
El departamento de matemáticas de la UT requiere un programa para realizar operaciones de calculo, las opciones son: suma, multiplicación, resta, división utilizando el operador /, división utilizando DIV, división utilizando MOD, Raíz cuadrada, exponente. El usuario debe elegir que operación desea realizar. Tenga en cuenta validar para las operaciones diferentes a suma y multiplicación, que el primer valor sea mayor que el segundo valor, de lo contrario no se debe permitir realizar la operación y se tiene que mostrar un mensaje en pantalla.

Algoritmo: hacer un programa que realice operaciones de calculo
que me dan?: suma, resta, división, multiplicación, raíz cuadrada, exponencicion
como lo hago?: verificando la operación a realizar
si es resta entonces res=n_mayor-n_menor
si es sume entonces sum=num_m+num_menor
si es multiplicación entonces mult=n_mayor*n_menor
si división entonces div=n_mayor/n_mayor
definición y declaración de variable y contanstes
var=res, sum, mult, div,¨cadena¨ n_mayor,n_menor¨real¨
entrada
n_mayor¨numero mayor¨ real
n_menor¨numero menor¨real
proceso
res¨resta¨cadena
sum¨suma¨cadena
mult¨multiplicacion¨cadena
div¨division¨cadena
programa oprracion de calculo
var n_mayor, n_menor, res, sum, mult, div
inicio
1.escriba¨numero mayor de la operación¨lea n_mayor
2.Escriba¨numero menor de la operación¨lean_menor
3.Si res=¨operación de calculo¨entonces
Res=n_mayor-n_menor
Fin_si
4.si sum=¨operación de calculo¨entonces
Sum=n_mayor+n_menor
5.si milt=¨ operación de calculo¨entonces
Mult=n_mayor*n_menor
Fin_si
6.si div=operación de calculo¨entonces
Div=n_mayor/n_menor
Fin_si
7.escriba¨resta¨,res
8.escriba¨suma¨,sum
9.escriba:multiplicacion¨,mult
10.escriba¨division¨,div
11.fin programa
Se modifica la instrucciones 3,4,5,6 de selectiva simple a selectiva alterna
3.si res=¨operación de calculo¨ entonces
Res=n_mayor-n_menor sino
Sum=n_mayor+n_menor¨ de lo contrario
Mult=n_mayor*n_menor¨de otra forma
Viv=n_mayor/n_menor
Fin_si
13.
En una tienda de videos se realiza una promoción para ciertos géneros de película, así: Suspenso 10% descuento, Drama paga una lleva dos, Romántica 30% descuento, Humor pague dos lleve cuatro. Los géneros se codifican: 1 Suspenso, 2 Drama, 3 Romántica, 4 Humor. El valor del alquiler de una película es $ 1200.oo. El programa debe calcular el valor a pagar por el cliente.

análisis del problema:
crear un programa que calcule el valor a pagar del cliente según la película que escogió y así mismo dicha promoción por tipo de esta.

que me piden?
calcular el valor a pagar del cliente.

que me dan?
los valores de descuento de cada película y sus promociones.

como lo hago?
debemos de conocer la clase de película así que hay que designar operaciones a cada una de estas clases y la cantidad porque así mismo se le dará el descuento al usuario.


algoritmo _ películas
inicio
1. escriba 1 película de suspenso
2. escriba 2 película de drama
3. escriba 3 película romántica
4. escriba 4 película de humor
5. digite la clase de película que quiere ver
6. digite el número de películas que quiere ver
7. si escoge la clase de película 1 entonces (numero de peliculas*valor de pelicula)-((numero de peliculas*valor de peliculas)*10/100).
8. si la clase de película es de numero 2 y lleva una entonces total = numero de peliculas *valor de pelicula.
9. si la clase de película es de numero 2 y lleva dos o mas películas entonces total = (valor de pelicula*numero de peliculas)/2.
10. si el tipo de película es de numero 3 entonces (numero de peliculas*valor pelicula)-((numero peliculas*valor pelicula)*30/100).
11. si el tipo de película es de numero 4 total= (valpel*numpel)/2
12. si el tipo de película es de numero 4 total = ((valpel*numpel)/2)-valpel.
13. mostrar resultados.
fin


declaración de constantes y variables:

constantes:
valpel = 1200

variables:
claspel entero
numpel entero
total real

algoritmo _ películas
inicio
cp = 0; total = 0; numpel = 0;
escriba “película de suspenso digite 1”;
escriba “película de drama digite 2”;
escriba “película romántica digite 3”;
escriba “película de humor digite 4”;
escriba “digite la clase de película que desea”; lea claspel;
escriba “digite el número de películas”; lea numpel;
si
claspel = 1
entonces
total = (numpel*valpel)-((numpel*valpel)*10/100);
escriba “total a pagar”; total;
sino
si
claspel = 2 ^ numpel = 1
entonces total = numpel*valpel;
escriba “total a pagar”; total;
finsi
sino
claspel = 2 ^ numpel >= 2
entonces
total = (valpel*numpel)/2;
escriba “total a pagar”; total;
finsi
fin si
sino
claspel = 3
entonces
total = (numpel*valpel)-((numpel*valpel)*30/100);
escriba “total a pagar”; total;
fin si
sino
si
claspel = 4 ^ numpel mod 2 = 0
entonces
total = (valpel*numpel)/2;
entonces “total apagar”; total;
fin si
sino
claspel = 4 ^ numpel mod 2 = 1;
entonces
total = ((valpel*numpel)/2)-valpel;
escriba “total a pagar”; total;
fin si
fin si
14.
Una empresa de viajes prepara un plan para excursiones con descuentos novedosos, para ello diseño la siguiente escala para grupos: Grupos de 15 a 20 personas tendrán un descuento del 10% del valor del tiquete, grupos hasta de 40 personas un descuento del 15% del valor del tiquete, grupos hasta 60 personas un descuento del 15% del valor del tiquete y una bonificación del 60% de un salario mínimo diario. Escriba un programa para calcular el valor que debe pagar una persona de acuerdo al grupo de personas con que viajara y la bonificación a que tiene derecho. Un salario mínimo legal mensual es de $ 461,500.oo.

Que me pidencalcular el valor a pagar por una persona de acuerdo al grupo
Que me dan:los grupos y los descuentos de cada grupo
Como lo hago?
Si es grupo 15 a 20 entonces vp=val_tik*des_10
Si es 40 entonces. Vp=val_tik*des_15
Si es grpo 60 entonces. Vp=val_tik*des_15+276.900
Si es bonificación entonces bonif=mini*60
Definición y declaración de variable y constante
var=tik¨real¨ vp=¨real¨
cons=des_10, des_15¨cadena ¨mini¨real¨
grupo ¨cadena¨ bonf
entradatik=¨precio de tiquete de vuelto¨real
des_10¨descuento de 10% para grupos de 15 a 20¨cadena
des_15¨descuento del 15% para grupos de 40¨cadena
mini¨salario minimo¨real
grup¨grupos de viajes¨cadena
proceso
vp¨valor a pagar de acuerdo agrupo¨real¨
bonif¨bonificacion 60% del salario minimo¨real
programa=agencia de viajes
var: tik,vp
cons:des_10, des_15, mini, bonif,
1.escriba¨precio del tikete¨lea tik
2.escriba¨descuento del 10% del grupo 15 al 20¨lea des_10
3.escriba¨descuento del 15% del grupo 40¨lea des_15
4.escriba¨salario minimo legal¨lea mini
5.escriba¨grupos de viajes¨lea grup
6.si grup=grupo de 15 a 20 entonces
Vp=tik*des_10
Fin_si
7.si grup=grupo 40 entonces
Vp=tik*des_15
Fin_si
8.si grup=grupo 60 entonces
Vp=tik*des_15+276.900
Fin_si
9.si bonif=bonificación del salario minimo entonces
Bonif=mini*60
Fin_si
10.escriba¨valor a pagar¨,vp
Escriba¨bonificacion salario minimo¨,bonif
Fin_programa
Se modifica 6,7,8 de selectiva simpley selectiva alterna
Si grup= grup de 15 a 20 entonces
Vp=tik*des_10
Sino
Vp=tik*des_15 de otra forma
Vp=tik*des_15+276.900
Fin_si
15.
La empresa de renta de vehiculos Rent a Naves cobra de acuerdo a la cantidad de kilómetros recorridos por el arrendatario, descontándolo de un monto dejado al recibir el vehículo, que puede ser 1:Moto o 2:Auto. Para ello tiene la siguiente tabla para liquidar el cobro: Para vehículos tipo 1 menos de 50 Kms $ 30,000, hasta 100 kms $ 60,000, mas de 100 Kms 60,000 mas un incremento de $ 500 pesos por km adicional; para vehículos tipo 2 menos de 70 Kms $ 50,000, entre 71 y 110 Kms $ 90,000, hasta 200 Kms $ 150,000, mas de 200 Kms 150,000 mas $ 3000 por Km adicional. Escriba un programa que liquide el valor que debe pagar una persona por el alquiler teniendo en cuenta la base dejada debe indicar si le sobra dinero o cuanto le falta.

Que me piden?: el valor que tiene que pagar una persona por el alquiler teniendo en cuenta la base
que me dan?:la tabla de liquidar el cobro
como lo hago?:verificando tipo de vehículo si es 1 o 2 y los kilómetros recorridos
si es vehículo tipo 1entonces vp=kms*pr_tb
si es vehículo tipo 2 entonces vp=kms*pr_tb
si es abono entonces =vpa=vp_abn
definición de variable y constante
entrada
kms¨kilometros recorridos¨real-vehiculo v1¨vehiculo de tipo 1´cadena
-vehiculo v2¨vehiculo de tipo 2¨ cadena
Pr_tb¨precios establecidos en la tabla¨ real-k500m¨costo adicional,en kilómetros pasados¨real
Abnäbono por el arriendo del vehiculo¨real k3000m¨costo adicional en kilómetros pasados¨real-abono¨abono por el arriendo¨real
Programa=renta de vehiculos
var=kms¨real¨,vp¨real¨abn¨real¨vpa¨real¨ abono¨real¨
cons=pr_tb¨real¨v1,v2¨cadena¨k500m,k3000m¨real¨
1.escriba¨kilometros recorridos¨lea kms
2.escriba ¨precios establecidos¨ lea pr_tb
3.escriba ¨abono por el arriendo del vehiculo¨ lea abn
4.escriba ¨vehiculo tipo1¨ lea v1
5.escriba ¨vehiculo tipo2¨ lea v2
6.escriba ¨adicional por kilómetros ¨lea k500m
7.escriba ¨adicional por kilómetros pàra tipo2¨ lea k3000m
8.escriba ¨abono arriendo por el abono¨ lea abono
9.si v1=menos de 50kmentonces
Vp=kms*pr_tb
sino
V1=hasta 100km entonces
Vp=kms*pr_tb
sino
V1mas 100km entonces
Vp=kms*pr_tb+k500m
Fin_si
10.si v2=menos 70km entonces
Vp=kms*pr_tb sino
Si v2 entre 71 y 110 km entonces
Vp=kms*pr_tb sino
Si v2=hasta 200km entonces
Vp=kms*pr_tb sono
Si v2 mas de 200km entonces
Vp=kms*pr_tb +k3000m
Fin_si
16.
Elabore un programa en el que se lea una temperatura en Grados centígrados (entre -15 y 120, el sistema debe rechazar cualquier valor que no este en este rango) y se indique el equivalente en grados kelvin y Fahrenheit.

análisis del problema
calculas en grados centígrados y en fahrenheit entre -15 y 120.

que me piden
grados centígrados y fahrenheit.

que me dan
grados centígrados y fahrenheit

como lo hago
ingresando un valor de grados centígrados que se encuentr-15 y 120, que lo convierta a grados kelvin y fahrenheit.

algoritmo _ grados
inicio
1. ingresar una temperatura dada en grados centígrados comprendida entre -15 y 120, sino esta entre este rango no la acepte.
2. calcular grados fahrenheit si los grados centígrados ingresados están entre -15 y 120.
3. calcular grados kelvin si los grados centígrados ingresados se encuentran entre -15 y 120.
4. mostrar resultados.
fin

declaración de constantes y variables:

constantes:

fc = 32
fk = 273
ff = 9/5

variables:

gk real
gf real
gc real

algoritmo _ grados
inicio
gk = 0; gf = 0; gc = 0;
escriba “digite cantidad de grados centígrados”; lea gc;
si
gc < -15 ^ > 120
escriba “el numero ingresado no se encuentra en el rango”;
sino
entonces gk = fk + gc;
gf = (ff * gc) + fc;
escriba “la cantidad en grados kelvin es:”; gk;
escriba “la cantidad en grados fahrenheit:”; gf;
fin si

LABORATORIO 1.


LABORATORIO 1



ejercicio:



Elabore un programa en el que se lea una temperatura en grados centígrados (entre -15 y 120) y se indique el equivalente en grados kelvin y farenheit.

1. Análisis: convertir grados centígrados a grados kelvin y a grados farenheit.

2. Qué me piden: grados kelvin y farenheit.

3. Qué necesito: grados centígrados

4. Cómo lo hago:

Constante:

FCGK= 273
FCGF= 9/5
FGC = 32

1. GK=GC+FCGK
2. GF=GC*9/5+32
3. GF=FCGF+FGC

ALGORITMO CONVER
Inicio
conocer datos de entrada
calcular grados kelvin
calcualr grados farenheit
mostrar resultados
fin

DEFINIR Y DECLARAR

Constantes:
FCGK = 273, FCGF= 9/5, FGC= 32;

Variables:
Entrada: GC = entero
Proceso: GK = entero
GF = real

LENGUAJE

# include
# define FCGK = 273
# define FCGF = 9/5
# define FGC = 32

using namespace std;
int GC, GK, TECLA;
Float GF

void main ()
{
GK= 0, GF= 0;
cout <<"cantidad grados centigrados:"; cin>> GC;
GK=GC+FCGK
GF=GC*(FCGF+FGC)
cout <<"\n Equivale en grados Kelvin a:"<
cout <<"\n Equivale en grados Farenheit a:"<
cin>>tecla;
}

LABORATORIO 2
Ejercicio:

Se ingresa por teclado las datos A, B y C. determine cuál es el mayor:

Algoritmo mayor
inicio
conocer datos de entrada
validar comparando los 3 datos para hallar el mayor
mostrar

si A>B y A>C entonces
may = A
si no

si B>C entonces
may= B
si no
may = C
fin si
fin si
fin si
Escriba" el mayor es:"; may
fin



LENGUAJE

# include

using namespace std;
int A, B, C, TECLA;

void main ()
{
may = 0;
cout <<\n primer valor:"; cin>> A;
cout <<\n segundo valor:"; cin>> B;
cout <<\n tercer valor:"; cin>> C;

{
if (A>B && A>C)
may = A;
}
else
{
if (B > C)
may = B;
}
else
may = C;

cout <<"\n el mayor es:"<
cin>>tecla;
}

viernes, 4 de diciembre de 2009

TALLER Nº 3






TALLER No. 3


1. Desarrolle los siguientes ejercicios, de acuerdo a lo que se pida.
1.1. Los sistemas operativos evolucionan aceleradamente entonces también lo tienen que hacer los lenguajes de programación y de igual manera sucede con el hardware.

a. Descomponga en las proposiciones simples.

• Los sistemas operativos evolucionan aceleradamente
• También lo tienen que hacer los lenguajes de programación
• De igual manera sucede con el hardware

b. Simbolice cada una de las proposiciones, y escriba la representación de la proposición completa.

R= Los sistemas operativos evolucionan aceleradamente
P= También lo tienen que hacer los lenguajes de programación
Q= De igual manera sucede con el hardware

R => (P^Q)

c. Cual es la conclusión.

R P Q R => P^Q
1 1 1 1 1
1 1 0 0 0
1 0 1 0 0
1 0 0 0 0
0 1 1 1 1
0 1 0 1 0
0 0 1 1 0
0 0 0 1 0


1.2. Construya proposiciones compuestas con las siguientes proposiciones.

A. La tecnología en computación basa su evolución en el descubrimiento del chip.
B. La tendencia de la tecnología apunta hacia la miniaturización de los componentes de hardware.
C. El procesador Intel Pentium Centrino, fue diseñado para equipos portátiles, con una tecnología que consume menos energía.
D. El futuro de los celulares apunta cada vez mas a ser equipos multifuncionales, que permiten realizar tareas de una palm, enlace a Internet y telefonía y lo mejor a muy bajos costos.

- La tecnología en computación basa su evolución en el descubrimiento del chip entonces la tendencia apunta hacia la miniaturización de los componentes del hardware.

- La tendencia apunta hacia la miniaturización de los componentes del hardware entonces el procesador Intel Pentium Centrino, fue diseñado para equipos portátiles, con una tecnología que consume menos energía.

- La tecnología en computación basa su evolución en el descubrimiento del chip o el procesador Intel Pentium Centrino, fue diseñado para equipos portátiles, con una tecnología que consume menos energía.

- La tendencia de la tecnología apunta hacia la miniaturización de los componentes de hardware o el futuro de los celulares apunta cada vez mas a ser equipos multifuncionales, que permiten realizar tareas de una palm, enlace a Internet y telefonía y lo mejor a muy bajos.

- La tecnología en computación basa su evolución en el descubrimiento del chip y la tendencia de la tecnología apunta hacia la miniaturización de los componentes de hardware.

1.3. Simbolice todas las proposiciones escritas en el punto anterior.

- A=>B
- B=>C
- A v C
- B v D
- A ^ B

1.4. Elabore proposiciones de todo tipo (atómicas y moleculares) y utilizando todos los términos de enlace revisados en el tema lógica proposicional. Los temas base para las proposiciones son.

a. Los videos juegos y sus aplicaciones en el rol diario de las personas, ventajas y desventajas de su utilización.

Podemos decir que un video juego y sus aplicaciones puede llegar a ser útil a una familia, lo cual entonces podemos decir que, una familia se puede reconfortar, pudiendo así pasar un momento agradable, sirve para un mejoramiento de la funcionalidad familiar, y conllevando a una integración, permitiendo que halla unión familiar.

b. Aportes y aplicaciones de la tecnología informática en la ciencia y la investigación.

Se puede llegar a una conclusión lógica y analítica que conlleva a un mejoramiento en el desarrollo de las ideas, para llegar a un mejor desempeño de la evolución científica, lo cual entonces podemos afirmar:

“Con el aporte de una idea se puede cambiar la forma de ver las cosas, y puede conllevar a muchas formas en la evolución científica para un mejor futuro de la humanidad”.


2. Tablas de Verdad.
Utilice 1 para Verdadero y 0 para Falso.
2.1. Elabore las tablas de verdad para Conjunción, Disyunción, Negación.

CONJUNCION
P Q P^Q
1 1 1
1 0 0
0 1 0
0 0 0

DISYUNCION
P Q P^Q
1 1 1
1 0 1
0 1 1
0 0 0

NEGACION
P Q ¬P ¬Q
1 1 0 0
1 0 0 1
0 1 1 0
0 0 1 1

2.2. Elabore las tablas de verdad para condicional y bicondicional.

CONDICIONAL
P Q PQ
1 1 1
1 0 0
0 1 1
0 0 1

BICONDICIONAL
P Q PQ
1 1 1
1 0 0
0 1 0
0 0 1


2.3. Que diferencia puede establecer entre 4.1 y 4.2. Identifique la lógica de cada una de ellas.

Rta/:
En las funciones de verdad como la conjunción y disyunción, encontramos que no se requieren condiciones, ya sean inscritas o impuestas para que se cumpla la función. En cambio las funciones condicionales y bicondicionales, encontramos que se requieren condiciones, ya sean inscritas o impuestas para que se cumpla la función.

Negación (¬),(~) : Consiste en cambiar el valor de verdad de una variable proposicional.

Conjunción : La proposición molecular será verdadera sólo cuando ambas variables proposicionales sean verdaderas.

Disyunción : La proposición molecular será verdadera cuando una o ambas variables proposicionales sean verdaderas.

Condicional (→) : La proposición molecular será verdadera cuando se cumpla si es verdadero A entonces lo es B.

Bicondicional (↔, si y sólo si): La proposición molecular será verdadera cuando ambas variables proposicionales tengan a la vez el mismo valor de verdad.

2.4. Demuestre la siguiente equivalencia: z → k ≡ ~ z v k.

Z K ZK
1 1 1
1 0 0
0 1 1
0 0 1
Z K ¬Z ¬Z v K
1 1 0 1
1 0 0 0
0 1 1 1
0 0 1 1

Z  K ≡ ~ Z v K



2.5. Elabore la tabla de Verdad para la proposición. K ^ ~(K v F).

K F K^ ¬ K v F
1 1 0 0 1
1 0 0 0 1
0 1 0 0 1
0 0 0 1 0


2.6. Demuestre si la tabla de verdad resultante para las siguientes proposiciones es igual: ~ (a ^d) ≡ ~a v ~d

a b ¬ a ^ b
1 1 0 1
1 0 1 0
0 1 1 0
0 0 1 0
A b ¬a v ¬b
1 1 0 0 0
1 0 0 1 1
0 1 1 1 0
0 0 1 1 1
¬ (a ^d) ≡ ¬a v ¬d

2.7. Determine las tablas de verdad para: a) (c → n) → (c ^ n)

a). (c → n) → (c ^ n)

c n c  n  c ^ n
1 1 1 1 1
1 0 0 1 0
0 1 1 0 0
0 0 1 0 0

b). (c → n) v ~ (c  ~ n)

c n ¬ n c  n v ¬ c  ¬ n
1 1 0 1 1 1 0
1 0 1 0 0 0 1
0 1 0 1 1 0 1
0 0 1 1 1 1 0


2.8. Construya la tabla de verdad para: [(m → b) ^b] → (~m ^b).

m b ¬ m mb ^b  ¬m^b
1 1 0 1 1 0 0
1 0 0 0 0 1 1
0 1 1 1 1 1 0
0 0 1 1 1 0 0


2.9. Simbolice y elabore la tabla de verdad para las proposiciones del ítem 2.4.

Podemos decir que un video juego y sus aplicaciones puede llegar a ser útil a una familia, lo cual entonces podemos decir que, una familia se puede reconfortar, pudiendo así pasar un momento agradable, sirve para un mejoramiento de la funcionalidad familiar, y conllevando a una integración, permitiendo que halla unión familiar.

V Podemos decir que un video juego
A sus aplicaciones puede llegar a ser útil a una familia
F podemos decir que, una familia se puede reconfortar, pudiendo así pasar un momento agradable. Sirve para un mejoramiento de la funcionalidad familiar
T conllevando a una integración, permitiendo que halla unión familiar



a. (V ^ A)(F ^ T)

V A F T (V ^ A) (F ^ T) (V ^ A)(F ^ T)
1 1 1 1 1 1 1
1 1 1 0 1 0 0
1 1 0 1 1 0 0
1 1 0 0 1 0 0
1 0 1 1 0 1 1
1 0 1 0 0 0 1
1 0 0 1 0 0 1
1 0 0 0 0 0 1
0 1 1 1 0 1 1
0 1 1 0 0 0 1
0 1 0 1 0 0 1
0 1 0 0 0 0 1
0 0 1 1 0 1 1
0 0 1 0 0 0 1
0 0 0 1 0 0 1
0 0 0 0 0 0 1

Se puede llegar a una conclusión lógica y analítica que conlleva a un mejoramiento en el desarrollo de las ideas, para llegar a un mejor desempeño de la evolución científica, lo cual entonces podemos afirmar:

“Con el aporte de una idea se puede cambiar la forma de ver las cosas, y puede conllevar a muchas formas en la evolución científica para un mejor futuro de la humanidad”.

A Se puede llegar a una conclusión lógica
B analítica que conlleva a un mejoramiento en el desarrollo de las ideas, para llegar a un mejor desempeño de la evolución científica
C Con el aporte de una idea se puede cambiar la forma de ver las cosas
D puede conllevar a muchas formas en la evolución científica para un mejor futuro de la humanidad

b. (A ^ B)(C ^ D)

A B C D (A ^ B) (C ^D) (A ^ B)(C ^ D)
1 1 1 1 1 1 1
1 1 1 0 1 0 0
1 1 0 1 1 0 0
1 1 0 0 1 0 0
1 0 1 1 0 1 1
1 0 1 0 0 0 1
1 0 0 1 0 0 1
1 0 0 0 0 0 1
0 1 1 1 0 1 1
0 1 1 0 0 0 1
0 1 0 1 0 0 1
0 1 0 0 0 0 1
0 0 1 1 0 1 1
0 0 1 0 0 0 1
0 0 0 1 0 0 1
0 0 0 0 0 0 1




2.10. Demuestre por medio de tablas de verdad una tautología, contradicción y contingencia. Explique en que consiste cada una de ellas.

 TAUTOLOGIA: Una proposición es una tautología cuando el valor de la forma proposicional es siempre verdad, independientemente de los valores de las propocisiones componentes.

P Q P ^ Q  Q v P
1 1 1 1 1
1 0 0 1 1
0 1 0 1 1
0 0 0 1 0

 CONTRADICCION: Una proposición es una contradicción cuando el valor de la forma proposicional es siempre falso, independientemente de los valores de las proposiciones componentes.

P Q ¬Q (P ^ Q) ^ ¬Q
1 1 0 1 0
1 0 1 0 0
0 1 0 0 0
0 0 1 0 0

 CONTIGENCIA O PROPOSIONES INDETREMINADAS: Una proposición es una contigencia cuando en la ultima columna efectuada de la tabla de verdad correspondiente aparece algunas veces el valor verdadero y otras el falso.

P Q ¬Q (P ^ Q) v (P ^ ¬Q)
1 1 0 1 1 0
1 0 1 0 1 1
0 1 0 0 0 0
0 0 1 0 0 0

3. Evalué las siguientes expresiones e indique el resultado en términos de 1 (Verdadero) o 0 (Falso).
R=25.5, Z=37, F= -4, W= -2

a. ((R * W) > Z) o ((F ^ 2) > R)
(-51 > 37) v (16 > 25.5)
1 0
0


b. (R > (W * W)) y ((F ^ 3) > Z)
(25.5 > 4) ^ (-64 > -2)
1 0
0

c. ((R > (Z *-1)) o (F < W) )) y (W > F)
(25.5 > 2) v (-4 < -2) ^ (-2 > -4)
1 1 1
1
1

d. (Z > R) y ((F ^ 2) > 0) y ((W *-1) < 0)
(37 > 25.5) ^ (16 > 0) ^ (2 < 0)
1 1 1
1 1
1

e. (R > (F ^ 4)) o (((R * 2) > Z) y (F > (W * -2)))
(25.5 > 256) v (51 > 37) ^ (-4 > 4)
0 1 0
0
0

4. Indique si es falso o verdadero y sustente su respuesta.

4.1 Los tipos de datos estructurados también se conocen como compuestos por tener un operador lógico que los une.

R/ verdadero por que el operador logico los une

4.2 Con los tipos de datos estructurados se puede almacenar datos de forma permanente en un medio magnético (ej. Disco duro, cinta magnética).

R/falso por que se almacenan temporalmente en la memoria RAM

4.3 Los arreglos o arrays, son una aplicación de los datos estructurados, que se clasifican en unidimensionales, bidimensionales y multidimensionales.

R/verdadero por que los arreglos se clasifican de acuerdo con el numero de dimensiones que tienen
*unidimensional (vectores)
*bidimensional (tablas)
*multidimensional (tres o mas dimensiones)

4.4 Para hacer referirse a cada posición dentro de un arreglo se utilizan subíndices.

R/ verdadero por que facilita utilizar los componentes de un arreglo.

4.5 Un subíndice es un valor que sirve para indicar el contenido de un arreglo en cualquiera de sus N posiciones.

R/ es verdadero por que los subíndices nos proporciona un mejor componente para un arreglo.

4.6 En su forma más simple se puede definir como registro a una estructura de datos que se compone de campos y que son atributos de un individuo u objeto.

R/verdadero solo varía dependiendo solamente del tipo de usuario que se tenga

4.7 La estructura registro es un tipo de dato definido por el usuario que permite almacenar datos del mismo tipo.

R/ verdadero porque está definido por el usuario

4.8 Se puede utilizar un arreglo de cualquier tipo para almacenar registros.

R/ falso por que el arreglo es únicamente cuando el tipo de registro es muy extenso.






EJERCICIOS
Para solucionar los problemas de programación que se enumera a continuación, debe aplicar los pasos sugeridos para solucionar un problema de programación de la Unidad IV. Luego de escribir el 4º. Paso (programa en seudo lenguaje), haga la prueba de escritorio.
5. Ejercicios de programación:

5.1 Escriba un programa que permita almacenar los datos para uno de los meses del año. Teniendo en cuenta que la estructura del registro contiene: numero del mes, nombre del mes, numero de días. El programa debe permitir capturar un solo Mes. Para este programa utilice tipo de dato registro (tipo de dato definido por el usuario).

Solución

Análisis:
Diseñar un programa que nos muestre los meses del año

Que me Piden:
Capturar los datos de un solo mes

Que me dan:
Numero del mes, nombre del mes, numero de días.

Como lo hago:
Realizar un registro de 3 partes con:
Numero del mes, nombre del mes, numero de días.

Algoritmo: mes
Inicio:
Realizar registro con las tres partes asignadas
Capturar número del mes
Capturar nombre del mes
Capturar número de días
Mostrar resultado del registro
Fin

Declaración de constantes y Variables
Entrada: tipo de registro: mes
Enteros: NUME _MES
NUME _DIAS
Cadena: NOM_ DE _MES

SEUDOLENGUSJE
Programa: mes
Tipo registro: MES
Entero: NUME_MES , NUME_DIAS
Cadena: NOM_DE_MES[11]
Fin registro
Var
Registro: MES
Inicio
Escriba”Digite número de mes:”, lea NUME_MES
Escriba”Digite número de días:”, lea NUME_DIAS
Escriba”Digite nombre del mes:”, lea NOM_MES
Escriba”El número de mes es:”, NUME_MES
Escriba”El número de días es:”, NUME_DIAS
Escriba”El nombre del mes es:”, NOM_MES
Fin

Prueba Escritorio

NUME_MES NUME_DIAS NOM_MES
3 31 Marzo
8 31 Agosto


5.2 Escriba un programa cuya declaración permita almacenar el numero de días de los meses del año en una estructura arreglo lineal. El programa debe permitir capturar un solo Mes. Para este programa utilice tipo de dato arreglo lineal (tipo de dato de una sola dimensión).

Análisis:
Elaborar un programa que permita almacenar el numero de dias de los meses del año consultando un mes

Que me Piden:
El numero de días de los meses del año capturando un mes

Que me dan:
Numero de dias y nombre mes

Como lo hago:
Creamos 2 registros
Uno para los dias que tiene cada mes del año
Y el otro para capturar el mes que queremos.

Algoritmo:
Inicio:
Crear registros 2
Consultar número de días
Consultar nombre mes
Mostrar resultado
Fin

Declaración de constantes y Variables
Entrada:
Tipo Entero
Array Num_Dias (365)
Entero array mes (12)

SEUDOLENGUSJE
Programa: meses
Tipo entero: array (Num_Dias; Nom_Mes)
Inicio
Escriba”Digite númerodias del mes:”, lea NUM_DIAS
Escriba”Digite número del Mes:”, lea Mes
Mostar resultados
Fin
5.3 Escriba un programa cuya declaración permita almacenar los datos para cada uno de los meses del año. Teniendo en cuenta que la estructura del registro contiene: numero del mes, nombre del mes, numero de días. El programa debe permitir capturar un solo Mes. Para este programa utilice tipo de dato arreglo lineal y registro (el arreglo de registros permite almacenar varias estructuras registro, simulando lo que se puede hacer con un archivo de datos).

Análisis:
Elaborar un programa que permita almacenar los datos para cada uno de los meses del año

Que me Piden:
Almacenar los adtos para cada uno de los meses

Que me dan:
Numero de mes
Nombre del mes
Numero de dias

Como lo hago:
Creamos 3 registros uno para el numero de meses
Uno para el nombre del mes y otro para numero de dias del mes

Algoritmo:
Inicio:
Consultar numero de mes
Consultar nombre mes
Consultar numero de dias
Mostrar resultados
Fin

Declaración de constantes y Variables
Nom_mes cadena
Num_mes entero
Num_dias entero

SEUDOLENGUSJE
Programa: mes
Variables
Nom_mes cadena
Num_mes entero
Num_dias entero
Inicio
Escriba”Digite nombre mes:”, lea Nom_mes
Escriba”Digite numero mes:”, lea Num_mes
Escriba”Digite numero dias mes”, lea Num_dias
Fin








5.4 Escriba un programa cuya declaración permita almacenar en un arreglo las edades de los estudiantes de cuatro (4) cursos (cada curso tiene 5 estudiantes). El programa debe permitir almacenar la edad del primer estudiante del curso 1. Para ello utilice el tipo de arreglo matriz o bidimensional.

Análisis:
Elaborar un programa que permita almacenar la edad del primer estudiante del curso

Que me Piden:
Almacenar las edades de los estudiantes de los cuatro cursos y almacenar la edad del estudiante del curso 1.

Que me dan:
Numero estudiantes
Numero de cursos
Edad estudiante

Como lo hago:
Se tiene que consultar la edad del primer estudiante del curso 1 y capturarla
Algoritmo: Edad de estudiantes
Inicio:
Consultar edad de estudiantes
Consultar curso de estudiantes
Mostar resultados
Fin
Declaración de constantes y Variables
Constantes
Num_cur entero
Num_ Estu entero
Variable
Edad_estu entero

SEUDOLENGUSJE
Programa: Edad de estudiante
Constantes:
Num_Cur entero
Num_ Estu entero
Variable
Edad_estu
Inicio
Escriba”Digiteedad del estudiante:”, lea Edad_estu
Escriba”Digite número de curso:”, lea NUM_cur
Escriba”Digite numero de estudiantes”, lea Num_estu
Fin










5.5 En la oficina de registro académico de la U.T. se almacena las notas de los estudiantes por asignatura, para ello el registro de datos tiene la siguiente estructura: Código estudiante, Nombres, apellidos, código asignatura, nota. Escriba un programa cuya declaración permita almacenar los datos de los estudiantes. El programa debe permitir almacenar los datos de un estudiante. Para este programa utilice el tipo de dato arreglo lineal y registro (el arreglo de registros permite almacenar varias estructuras registro, simulando lo que se puede hacer con un archivo de datos).

Análisis:
Elaborar Programa que permita almacenar los datos de los estudiantes

Que me Piden:
Almacenar Datos de un estudiante

Que me dan:
Código estudiante, nombres, apellidos, código asignatura, nota

Como lo hago:
Basándome del código del estudiante me dan nombre apellidos código de asignatura y nota

Algoritmo: Datos Estudiante
Inicio:
Realizar registro y array lineal
Capturar Código estudiante,
Capturar nombres
Capturar apellidos
Capturar código asignatura
Capturar nota
Mostrar resultado del registro y array lineal
Fin

Variables
Entrada: Tipo De Registro: Código Estudiante
Enteros: C_ASIG
N
Cadena: array [15] NOM
Array [12] APE



SEUDOLENGUSJE
Programa: Datos Estudiante
Tipo registro: Código Estudiante
Entero: C_ASIG, N
Cadena: NOM, APE
Fin registro
Var
Reg: Código estudiante
:Inicio
Escriba”Digite Código estudiante:”, lea C_ESTU
Escriba”Digite nombres:”, lea NOM
Escriba”Digite Apellidos ”, lea APE
Escriba”Digite Código asignatura:”, lea C_ASIG
Escriba”Digite nota:”, lea N
Mostra resultados
Fin




5.6 La serie de fibonnaci es una serie numérica que se genera de la siguiente forma:

0 + 1 = 1

1 + 1 = 2

1 + 2 = 3
2 + 3 = 5
3 + 5 = 8
5 + 8 = 13
Escriba un programa cuya declaración permita almacenar los resultados de generar los números de la serie. El programa debe almacenar los datos por asignación, resultante del calculo. La estructura del registro la debe definir usted, con los campos que crea conveniente o necesarios. El programa debe permitir almacenar los valores para la primera línea de la serie de fibonnaci. En este caso es importante que analice que tipo de dato estructurado utilizara.

TALLER Nº 2.






1. Responda todas las preguntas generadoras de las unidades III, IV y V del proyecto pedagógico.

UNIDAD III

De acuerdo a la evolución de la tecnología respecto de los computadores, ¿cómo califica la evolución del software?
Mediante el tiempo el software ha obtenido muchos cambios ha ido evolucionando muy rápido al igual que la tecnología con respecto a los computadores ( hardware) esto se debe que mediante de lenguajes de programas el computador trabaja de una manera simple , sencilla y optima para el rendimiento de la computadora.

¿Cuál es el esquema para solucionar un problema por medio de un algoritmo, diagrama de flujo y seudo lenguaje? Identifique cada parte dentro de ella.
Los cinco pasos que se debe llevar a cabo en el área de la programación en la construcción de la solución de un problema para que se realice de una forma clara y segura la solución del problema planteado.

Análisis del problema:
Primer paso,
Analizar y comprender el enunciado del problema comprendiendo que se pide solucionar y hacer un diseño de la solución teniendo en cuenta tres preguntas esenciales para dicha solución del problema las cuales son:
¿Qué me piden?
Darle solución al problema planteado y que e tiene que lograr mediante la solución del problema.
¿Qué me dan o que tengo?
Se deber tener en cuenta los datos de entrada y los datos constantes lo cuales se plantea en el enunciado del problema en algunas ocasiones no los muestra de esta manera nos pide que los encontremos en el problema.

¿Cómo lo hago?
Enfocarnos a la solución del problema por medio de los procedimientos o con las formulas
Algoritmo:

Tener claro el significado y propósito de algoritmo, cual es el lenguaje en que se escribe, cuáles son sus partes escribiendo el algoritmo para solucionar el problema.

Definición de Constantes y Variables:

Este paso se debe tener como prioridad clasificar los datos y asignarles identificadores y se debe agrupar en tres categorías entrada, proceso y salida
teniendo en cuenta el contenido y utilización de las variables.

Seudo Algoritmo o Seudo Lenguaje:
Se debe escribir las partes solucionadas en los tres pasos mencionados anteriormente en el programa de seudo lenguaje teniendo en cuenta las partes de un programa.

Prueba de escritorio:

Recurso Matemático-lógico se realiza un seguimiento a cada una de las instrucciones del programa (algoritmo) para comprobar su funcionamiento de forman manual si realmente funciona es una ejecución ‘a mano’ or lo tanto se debe llevar registro de los valores que va tomando cada una de las variables involucradas en el mismo.







¿En qué casos de su vida cree ha utilizado algoritmos mentalmente para desarrollar alguna actividad?
Los algoritmos en la mayoría de la ocasiones los utilizamos para actividades de la vida cotidiana como por ejemplo cuando realizamos una suma , resta . división y multiplicación mentalmente ahora cuando vamos de mercado con la familia llevamos un presupuesto de dinero limite el cual no se puede pasar cuando empacamos ene l carrito de mercado vamos haciendo mentalmente la cuenta para cuando llegamos a la caja ya tengamos un idea del valor a pagar.

¿Qué diferencias puede establecer entre algoritmo, diagrama de flujo y seudo lenguaje?


Los diagramas de flujo es una forma de representar gráficamente algoritmos; usan símbolos conectados con flechas para indicar la secuencia de instrucciones, usados para representar algoritmos pequeños, por lo que abarcan mucho espacio y su construcción es laboriosa. Mientras los Pseudocódigo o Pseudolenguaje es la descripción de un algoritmo que se asemeja a un leguaje de programación, tiene distintas ventajas con respecto a los diagramas de flujo entre las que se destaca el poco espacio que requiere para representar instrucciones complejas. En conclusión un diagrama de flujo y un seudo lenguaje son las formas o las maneras más estructuradas y ordenadas que se utilizan para representar algoritmos, pero son independientes de un lenguaje de programación específico. Y los algoritmos son un conjunto de operaciones definidas, ordenadas y finitas que nos permite hallar la solución de un problema.


¿De los tres cual le parece más práctico y fácil de utilizar? ¿Porque?

Nos parece que el método aunque no es el más práctico y fácil de usar, pero a su vez puede resultar interactivo su utilización y facilitar el proceso de aprendizaje, son los Diagramas de Flujo; ya que es una representación grafica o en forma de diagrama ordenada y estructurada de los algoritmos que se utilizaran para solucionar algún tipo de problema con un determinado programa.


¿Cree que en la solución a un problema los debamos utilizar todos? Justifique.

Pensamos que no necesariamente se tienen que utilizar todos, pero es importante tener en cuenta que para enfocarnos a la solución de un problema, primero lo que tenemos que hacer es utilizar los algoritmos o las operaciones, y segundo escoger la manera adecuada y conveniente de acuerdo al caso o problema que estemos solucionando para representar estos algoritmos. Pero se recomienda representar la solución de problemas mediante la descripción de palabras de los procedimientos y además mediante un esquema de la estructura del programa para así comprender la ubicación de cada parte dentro del esquema.


¿Cuál de los tres es menos utilizado? Justifique.

Debido a lo explicado anteriormente, pensamos que los tres métodos de solución a problemas planteados son utilizados de igual manera, ya que uno se encarga como de la parte de describir con palabras la solución (seudo lenguaje), el otro juega una parte importante en cuanto a las operaciones aritmético-lógicas (algoritmo) y el ultimo es el esquema o dibujo que realizamos para un mejor y más fácil entendimiento de la solución que planteamos a cualquier problema

UNIDAD IV
Como puede elaborar el esquema de la estructura de un programa e identificar cada parte dentro de ella.
Conocer el esquema de cómo se integra un programa es importante, para que siempre se tenga en cuenta en qué posición debe ir cada conjunto de instrucciones.

Encabezado:
Esta sección del programa se integra por:
Nombre del programa: El identificador que hace alusión al nombre del programa que se resuelve.

Zona de declaración:
Esta sección contiene la declaración de Constantes y variables.
Constantes: Aquí se declara todos los identificadores con los valores constantes identificados para el programa.
Variables: Aquí se declara los identificadores para los datos del programa, clasificados por tipo de dato.

Cuerpo del programa:
En esta sección del programa se coloca todas las instrucciones que integran la solución del problema. Es importante dibujar el esquema de la estructura del programa, para así comprender fácilmente la ubicación de cada parte dentro de dicho.

¿Porque el análisis es importante al momento de abordar el proceso para solucionar un problema?
En primer lugar, el análisis se toma como el primer paso para solucionar un problema de forma exitosa. Entonces vemos que es de suma importancia ya que es donde comprendemos el enunciado del problema y procedemos a abordar el correspondiente diseño de la solución del mismo.
Suponga que tiene el enunciado de un problema para resolver, ¿qué sería lo primero que debe hacer? ¿Y que lo que no debe hacer?
Si tenemos el enunciado de un problema el cual debemos resolver, en primer lugar lo que debemos hacer es su correspondiente análisis. Para así poder responder a tres preguntas esenciales que me permiten iniciar el desarrollo del análisis del problema. Primero ¿qué me piden?, segundo ¿qué me dan o que tengo? y tercero ¿cómo lo hago?
¿Qué pasos se debe tener en cuenta para solucionar un problema de programación?
Los pasos para realizar una solución eficiente a algún problema en programación, los cuales representan un alto grado de precisión y seguridad son los siguientes:
PASO 1. ANÁLISIS DEL PROBLEMA

PASO 2. ELABORACIÓN O ESCRITURA DEL ALGORITMO PARA LA SOLUCIÓN PROPUESTA.

PASO 3. DECLARACIÓN Y DEFINICIÓN DE CONSTANTES Y VARIABLES.

PASO 4. ESCRIBIR PROGRAMA EN SEUDO LENGUAJE.

PASO 5. PRUEBA DE ESCRITORIO.
¿Cómo puede aprovechar la utilización de un algoritmo, para la solución final en un programa escrito en Seudo lenguaje o seudo código?
Para la solución final de un programa escrito en Seudo Lenguaje, aprovechamos los algoritmos o las operaciones de estos de una manera ordenada y definida; para realizar la correspondiente y adecuada solución del determinado problema que se tiene frente algún programa.
UNIDAD V

¿Cuál es el grado de dificultad que representa los programas secuénciales?
En primer lugar los programas secuenciales nos sirven para aprender a programar en lenguaje C. Principalmente su dificultad se presenta ya que es donde se ve la manera de cómo manipular las variables de diferentes tipos de datos, como se realiza la entrada y salida de datos; desde y hacia los dispositivos periféricos. Mediante la utilización de las funciones de Entrada/Salida y como es necesario la generación de expresiones aritméticas correctas para la solución de problemas con un componente matemático desde el computador.
¿Cuándo realiza el análisis del problema, como identifica si es un problema para aplicar estructura secuencial?

La estructura lógica que más se usa para la solución de problemas, es la Estructura Secuencial, en todos los problemas que se presentan se utiliza esta estructura juntamente con una o más estructuras. La Estructura Lógica Secuencial, procesa una serie de instrucciones como su nombre lo indica consecutivamente de arriba hacia debajo de un algoritmo, la forma típica del algoritmo de esta estructura es:

• Tengo un teléfono y necesito llamar a alguien pero no sé cómo hacerlo.









1. Que es un lenguaje de programación?

Se define como un conjunto de símbolos que definen la estructura y lo que significa los elementos y expresiones controla el comportamiento de las maquinas física y lógica mente.



2. Revise la historia de los lenguajes de programación y su evolución. Identifique las etapas y la diferencia entre una y otra.
• Plankalkül (Konrad Zuse) lenguaje teórico, valores bits,
• 1943 - ENIAC computador e integrador numérico
• 1949 - C-10
• 1951 - Regional Assembly Language
• 1952 - Autocode
• 1954 - FORTRAN orientado al cálculo mayor eficacia
• 1958 - LISP tipo declarativo
• 1958 - ALGOL permiten comunicar algoritmos
• 1959 - COBOL dotado de unas excelentes capacidades de auto documentación, una buena gestión de archivos y una excelente gestión de los tipos de datos
• 1962 - APL Es un lenguaje muy conciso, con una sintaxis muy sencilla. Está orientado a trabajos con matrices, con la que se pueden hacer todo tipo de operaciones lógicas o matemáticas. Incluso se pueden definir nuevas operaciones matriciales.
• 1962 - Simula es el primer lenguaje de programación orientada a objetos
• 1964 - BASIC de enseñanza es un lenguaje de programación que originalmente fue desarrollado como una herramienta
• 1964 - PL/I responder simultáneamente a las necesidades de las aplicaciones científicas y comerciales,
• 1966 - BCPL Lenguaje de Programación Básico Combinado1969 - B es el nombre de un lenguaje de programación desarrollado en los Bell Labs, predecesor del lenguaje de programación C.1970 - Pascal Su objetivo crear un lenguaje que facilitara el aprendizaje de la programación a sus alumnos.
• 1972 - C es un lenguaje orientado a la implementación de Sistemas Operativos,
• 1972 - Smalltalk es un sistema informático que permite realizar tareas de computación mediante la interacción con un entorno de objetos virtuales. Metafóricamente, se puede considerar que un Smalltalk es un mundo virtual donde viven objetos que se comunican mediante el envío de mensajes.
• 1972 - Prolog es un lenguaje de programación lógico e interpretado, bastante conocido en el medio de investigación en Inteligencia Artificial
• 1990 - Haskell es un lenguaje de programación puramente funcional de propósito general y fuertemente tipado
• 1990 - Python En la actualidad Python se desarrolla como un proyecto de código abierto, administrado por la Python Software Foundation.
• 1991 - Java El lenguaje en sí mismo toma mucha de su sintaxis de C y C++, pero tiene un modelo de objetos más simple y elimina herramientas de bajo nivel, que suelen inducir a muchos errores, como la manipulación directa de punteros o memoria
• 1993 - Ruby es un lenguaje de programación interpretado, reflexivo y orientado a objetos
• 2000 - C# es un lenguaje de programación orientado a objetos desarrollado y estandarizado por Microsoft como parte de su plataforma .NET, que después fue aprobado como un estándar por la ECMA e ISO.
• 2007 - UAP
3 Què importancia tienen los lenguajes de programación en la computación

Es importante porque con los lenguajes podemos programar o darle funciones para que hagan tarea es necesario conocer sobre lenguaje para poder darle sus funciones.
4. Como se clasifican los lenguajes de programación?

Lenguajes de bajo nivel: Los lenguajes de bajo nivel son lenguajes de programación que se acercan al funcionamiento de una computadora. El lenguaje de más bajo nivel es, por excelencia, el código máquina
Lenguajes de medio nivel: Hay lenguajes de programación que son considerados por algunos expertos como lenguajes de medio nivel (como es el caso del lenguaje C) al tener ciertas características que los acercan a los lenguajes de bajo nivel pero teniendo, al mismo tiempo, ciertas cualidades que lo hacen un lenguaje más cercano al humano y, por tanto, de alto nivel.
Lenguajes de alto nivel: Los lenguajes de alto nivel son normalmente fáciles de aprender porque están formados por elementos de lenguajes naturales, como el inglés. En BASIC, pero este lenguajes dificultoso por que como el la maquina entiende lo que dice pero no como lo hace tiene que hablar sistemáticamente
5. Establezca la diferencia entre Algoritmo y Diagrama de flujo?
un diagrama de flujo es lo q vez. El algoritmo es lo q lo hace funcionar.
-un diagrama de flujo esta definido como la representación grafica de un algoritmo son complemento tan de una como se la otra.
-la diferencia es q un algoritmo es una serie de pasos para llegar a un fin determinado y un diagrama de flujo es una representación sistematizada y grafica de un algoritmo a trabes de simbolos los cuales se supone hacen mas facil el entendimiento del programa....el diagrama de flujo ademas puede ser aun mas especifico que el algoritmo.
En otras palabras, el algoritmo es ciencia y el D. Flujo es arte. El primero deduce, mientras que el segundo induce.
6. Que entiende por seudo lenguaje, seudo código o seudo algoritmo?
Es escribir un algoritmo en leguaje natural para pasarlo a lenguaje de programación.
El lenguaje natural seria el ejerció como tal.
El lenguaje del computador seria el idioma al que se va a pasar el problema.
7. Que papel desempeña el seudo lenguaje en el diseño de la solución de un programa? Explique.
El seudo lenguaje es la forma de expresar un algoritmo con un enunciado natural que puede resolver el problema con base a solucione de problemas (algoritmo)
8. Indique las partes de un programa? Esquematice las partes de un programa dentro de la estructura de un programa.
Encabezado: en el ira el nombre del programa a resolver.

Zona de declaración: es donde se declaran las constantes y las variables según el programa.

Declaración de variables: es donde se pone las variables del programa. (Las que nos dieron y las que necesitamos para resolver el problema).

Declaración de procesos y funciones: aquí es donde irán las funciones que quiere ponerle a su programa.

Cuerpo principal del programa: En esta sección del programa se coloca todas las instrucciones que integran la solución del problema.

Final del programa: después de una secuencia de pasos este seria el último paso donde encontraremos la solución del problema.
10. Que pasos se debe seguir para solucionar un problema de programación?

R= 1.Definicióndel problema
2.Análisis del problema
3.Selección de la mejor alternativa
4.Diagramación
5.Prueba de escritorio
6.Codificación
7.Trascripción
8.Compilación
9.Pruebas de computador
10.Documentación externa

11. Que es programación estructurada?

Programación Estructurada es una técnica en la cual la estructura de un programa, es, la interpelación de sus partes realiza tan claramente como es posible mediante el uso de tres estructuras lógicas de control:
Secuencia: Sucesión simple de dos o mas operaciones.
Selección: bifurcación condicional de una o mas operaciones.
Interacción: Repetición de una operación mientras se cumple una condición.
12. Que es programación modular?

Consiste en dividir un programa en subprogramas con el sentido de hacerlos manejables envés de resolver un problema grande y complicado resolvemos pequeñas partes de ese problema y haci llegar a una solución menos complicada.

13. Que significa el nuevo paradigma de programación, POO (programación orientada a objetos).

R= La programación Orientada a objetos (POO) es una forma especial de programar, más cercana a como expresaríamos las cosas en la vida real que otros tipos de programación.
Con la POO tenemos que aprender a pensar las cosas de una manera distinta, para escribir nuestros programas en términos de objetos, propiedades, métodos y otras cosas que veremos rápidamente para aclarar conceptos y dar una pequeña base que permita soltarnos un poco con este tipo de programación
14. Que lenguajes de programación existe en la actualidad y que características importantes puede mencionar de cada uno. (ámbitos de aplicación, potencialidades, costo, sistema operativo sobre el que trabaja).

R=rubi Un lenguaje de programación dinámico y de código abierto enfocado en la simplicidad y productividad. Su elegante sintaxis se siente natural al leerla y fácil al escribirla.
C# es un lenguaje de propósito general orientado a objetos creado por Microsoft para su plataforma .NET.
Su sintaxis básica deriva de C/C++ y utiliza el modelo de objetos de la plataforma .NET el cual es similar al de Java aunque incluye mejoras derivadas de otros lenguajes. C# fue diseñado para combinar el control a bajo nivel de lenguajes como C y la velocidad de programación de lenguajes como Visual Basic.
Xen: Es una mezcla del Common Language Runtime (CLR) de Microsoft con XML y SQL. La idea principal es empotrar el manejo de datos XML y SQL dentro del lenguaje.
Python: Python es un lenguaje creado alrededor de las metodologías de desarrollo Agile.
El objetivo fundamental de Python es incrementar la productividad del desarrollador, aún a costa de eliminar cualidades que algunos puristas de la programación orientada a objetos consideran irrenunciables, como el chequeo estático de tipos.
Tutorial D: Es una propuesta para solucionar algunos de los problemas de diseño inherentes
15. Que estructras de programación conoce? Explique

R=Selección doble= Son estructuras lógicas que permiten controlar la ejecución de varias acciones y se utilizan cuando se tienen dos opciones de acción, por la naturaleza de estas se debe ejecutar una o la otra, pero no ambas a la vez, es decir, son mutuamente excluyentes.
Selectivas compuestas= En la solución de problemas encontramos numerosos casos en los que luego de tomar una decisión y marcar el camino correspondiente a seguir, es necesario tomar otra decisión. Dicho proceso puede repetirse numerosas veces. En aquellos problemas en donde un bloque condicional incluye otro bloque condicion al se dice que un bloque está anidado dentro del otro.
Selectivas multiples= Con frecuencia es necesario que existan más de dos elecciones posibles. Este problema se podría resolver por estructuras selectivas simples o dobles, anidadas o en cascada, pero si el número de alternativas es grande puede plantear serios problemas de escritura y de legibilidad.







16. Que diferencia puede establecer entre una estructura secuencial y una estructura condicional.

R= La estructura secuencial es aquella en la que una acción (instrucción) sigue a otra en secuencia. Las tareas se suceden de tal modo que la salida de una es la entrada de la siguiente y así sucesivamente hasta el fin del proceso.

Una ESTRUCTURA CONDICIONAL es aquella que nos permite "preguntar" sobre el entorno que nos rodea, pudiendo así actuar según la respuesta obtenida. Estas respuestas siempre serán Verdadero o Falso, pudiendo así tomar, en un principio, dos caminos diferentes.



















Problemas
1. Escribir un algoritmo que lea un valor entero, lo duplique, luego lo multiplique por 25 y al final muestre el resultado.
ANALISIS DEL PROBLEMA: escribir un programa que tome un número entero, lo duplique luego lo multiplique por 25 y muestre el resultado.
Que me piden: El resultado de multiplicar un entero por dos y luego por 25.
Que me dan: Un número entero.
Como lo hago: con una multiplicación, res= num * 2 * 25

Algoritmo numero entero
Inicio
1. Conocer numero entero
2. Calcular resultado de multiplicar por dos y por 5
3. Mostrar resultado
Fin

declaración de variables:
Entrada: num: real
Proceso: res

Programa en seudo código
Programa numero entero
var.
num, res: entero
inicio
escriba “Digite un numero entero: “, lea num
res = num * 2* 25
escriba “ El resultado es: “, res
fin
1.5 Prueba de escritorio:
num=10
res= 10 * 2 * 25
res = 500
2. Escriba un algoritmo que lea cuatro datos A,B,C y D, calcule e imprima su producto, la suma y la media aritmética.
1.ANALISIS DEL PROBLEMA Escribir un programa que tome 4 datos y calcule su producto, suma y media aritmética y muestre los resultados.
Que me piden: el producto, la suma y la media aritmética de 4 datos
Que me dan: cuatro datos iníciales.
Como lo hago:
- tomo los 4 datos y calculo su producto: prod = A * B * C * D
- tomo los 4 datos y calculo su suma: sum = A + B + C + D
- tomo el resultado de la suma y lo divido en 4 para hallar la media aritmética.
med_arit = sum / 4


2.Algoritmo hallar producto, suma y media aritmética
inicio
1. Conocer los datos de entrada A, B, C, D
2. Calcular su producto
3. Calcular la suma
4. Calcular la media aritmética
5. mostrar los resultados del producto, suma y media aritmética
fin

3.declaración de variables
entrada: A, B, C, D : real
proceso: prod, sum, med_arit : real

4.Programa en seudo código
Programa Hallar producto suma y media
var.
A, B, C, D, prod, sum, med_arit : real
inicio
escriba “Introduzca dato A: “ lea A
escriba “introduzca dato B: “ lea B
escriba “introduzca dato C: “ lea C
escriba “introduzca dato D: “ lea D
prod = A * B * C * D
sum = A + B + C + D
med_arit = sum / 4
escriba “ El producto es: “, prod
escriba “ La suma es: “, sum
escriba “ La media aritmética es: “, med_arit
fin

2.5 Prueba de escritorio
A=50, B=40, C=30, D=55
prod= 50 * 40 * 30 *55, prod=3300000


3. Escriba un programa en el que se lea el peso de un hombre en libras y devuelva su peso en kilogramos y gramos. (Una libra equivale a 0.453592 kilogramos).

1.ANALISIS DEL PROBLEMA: Escribir un programa que tome un número dado de libras y calcule y exprese su valor en Kilogramos y en gramos.
Que me piden: Expresar en Kg. y gramos un número dado en libras.
Que me dan: Un número determinado de libras y el equivalente de 1 libra en Kg.
Como lo hago:
- el numero de libras lo multiplico por 0.453592 para pasarlo a Kg:
pesokg = pesolib * 0.453592
- el resultado en Kg. Lo multiplico por mil para pasarlo a gramos:
pesogr = pesokg * 1000

2.Algoritmo para pasar de libras a Kg. Y a gramos.
Inicio
1. Conocer el numero de libras
2. Expresarlo en kilogramos
3. Expresarlo en gramos
4. Mostrar los resultados
Fin

3.declaración de variables:
Entrada: pesolib: real
Proceso: pesokg, pesogr: real

4.programa en seudo código
Programa pasar de libras a kilogramos y gramos.
var.
pesolib, pesokg, pesogr : real
Inicio
escriba “ Peso en libras: “ lea pesolib
pesokg = pesolib * 0.453592
pesogr = pesokg * 1000
escriba “ equivalente en kilogramos: “, pesokg
escriba “ equivalente en gramos: “, pesogr
fin.

5.Prueba de escritorio:
pesolib = 2.5
pesokg = 2.5 * 0.453592, pesokg = 1.13398
pesogr = 1.13398 * 1000 pesogr = 1133.98

4. Escriba un algoritmo en el cual se ingrese por teclado un peso en kilogramos mayor a cero (0) y el programa lo convierta a toneladas y arrobas.

1.ANALISIS DEL PROBLEMA: escribir un programa que lea un peso en kg mayor que cero, y lo exprese en toneladas y en arrobas.
Que me piden: expresar en toneladas y arrobas un peso en kilogramos.

Que me dan: el peso en kg que debe ser mayor que cero
Como lo hago:
- para pasar de kg a toneladas multiplico por 0.001:
ton = kg * 0.001
- para pasar de kg a arrobas divido por 12.5
arro = kg / 12.5

2.Algoritmo para convertir kg en toneladas y arrobas
inicio
1. Conocer el número de kg
2. si es mayor que 0 entonces:
calcular el equivalente en toneladas
calcular el equivalente en arrobas
mostrar equivalente en toneladas y en arrobas
si no:
mostrar mensaje de error al ingresar el dato.
3 fin de la condición
4. fin

3.definición de variables:
Entrada: kg : real
proceso: ton, arro

4.programa en seudo código
programa convertir kg en toneladas y arrobas
var.
kg, ton, arro : real
inicio
escriba “ingrese peso en kilogramos mayor de 0: “ lea kg
si kg > 0 entonces:
ton = kg * 0.001
arro = kg / 12.5
escriba “ Equivalente en toneladas: “, ton
escriba “ Equivalente en Arrobas: “, arro
si no:
escriba: “El numero ingresado debe ser mayor que 0: “
fin del condicional
fin.

5. Prueba de escritorio:
kg = 250.5
ton = 250.5 * 0.001 ton = 0.2505
arro = 250.5 / 12.5 arro = 20.04
5. Escriba un programa que permita calcular el área y el volumen de un cilindro.
1.ANALISIS DEL PROBLEMA: escribir un programa que me calcule el area y el volumen de un cilindro, debo conocer el radio la altura del cilindro.

Que me piden: calcular el area y el volumen de un cilindro
Que me dan: El radio y la altura del cilindro
Como lo hago:
- para hallar el area debo multiplicar la constante pi por 2, luego por el radio y la altura y sumarle 2 por pi por radio al cuadrado: a =( 2 * pi * r * h) +( 2 * pi * r**2 )
- para hallar el volumen multiplico la constante pi por radio al cudrado y luego por la altura: vol = pi * r**2 * h


2.Algoritmo calcular el area y el volumen de un cilindro
inicio
1. conocer el radio y la altura del cilindro
2. calcular el area
3. calcular el volumen
4. mostrar el area
5. mostrar el volumen
fin.

3. Declaración de variables
entrada: r, h : real variables
proceso: a, vol : real variables
pi : real costante

4.programa en seudo código
programa calcular el área y volumen de un cilindro
var.
r, h, a, vol : real
cos
pi=3.1416. real

inicio
escriba “el radio del cilindro es: “ lea r
escriba “la altura del cilindro es: “ lea h
a =( 2 * pi * r * h )+ (2 * pi * r**2)
vol = pi * r**2 * h
escriba “El área del cilindro es: “, a
escriba “El volumen del cilindro es: “, vol
fin

5. prueba de escritorio:
r=5, h=4.5
a = (2 * 3.1416 * 5 * 4.5) +( 2 * 3.1416 * 5**2), a = 298.45
vol = 3.1416 * 5**2 * 4.5 , vol = 353.43
6. Escriba un programa para calcular el área y el volumen de un paralelepípedo.

1.ANALISIS DEL PROBLEMA: para realizar el programa que me calcule el area y el volumen de un paralelepipedo, debo conocer el perímetro de la base, su altura y el área de la base y aplicar la formula correspondiente.
Que me piden: calcular el area y el volumen de un paralelepipedo

Que me dan: los datos que necesito son el perímetro y el area de la base, tambien la altura del paralelepipedo.

Como lo hago:
1. conocer los datos del paralelepípedo, perímetro y area de la base, altura.
2. calcular el area del paralelepípedo usando la formula a = p*h+2*B donde p es el perímetro de la base, h la altura y B el area de la base
3. calcular el volumen usando la formula v=B * h, donde v esvolumen, B el area de la base y h la altura.

2.Algoritmo calcular el area y elolumen de un paralelepípedo.
inicio
conocer el perímetro de la base, la altura y el area de la base del paralelepípedo
calcular el area
calcular el volumen
mostrar area
mostrar volumen
fin.

3.declaracion de variables:
Entrada: p : perímetro de la base, real
h : altura,real
B : area de la base, real
proceso: a : area del paralelepípedo, real
v: volumen del paralelepípedo, real

4.programa en seudo código
programa calcular area y volumen de un paralelepípedo.
var.
p, h, B, a, v : real
escriba “ingrese el perímetro de la base del paralelepípedo: “ lea p
escriba “ingrese la altura: “ lea h
escriba “ingrese el area de la base: “ lea B
a = p*h+2*B
v=B * h
escriba “el área del paralelepípedo es: “, a
escriba “el volumen del paralelepípedo es: “, v
fin.

5.Prueba de escritorio:
calcular el area de un paralelepipedo, cuya altura es 10 cm, el perímetro de la base 25 cm y el area de la base 25 cm cuadrados

a = p*h+2*B
a= 25 * 10 + 2 * 25
a= 300

v= B * h
v = 25 * 10
v= 250.
7. Escriba un programa que permita para el programa 6., incrementar uniformemente cada una de las caras y determine su nueva área.
1.ANALISIS DEL PROBLEMA: Escribir un programa que calcule el area de un paralelepípedo y me permita incrementar cada cara teniendo las tres medidas del mismo
Que me piden? Hallar area e incrementar cada cara y hallar ara nuevamente
Que me dan? Medidas del paralelepípedo y cantidad a incrementar
Como lo hago?
1. hallo el area de cada una de sus caras sumo los tres valores y los multiplico por 2 para el area
A_PLPD = 2((A * B) + (B * C) + (A * C))
2. multiplico las medidas de los lados para hallar el volumen
V_PLPD= A *B *C
3. sumo el incremento a cada cara
(A = A + INCR)
(B = B + INCR)
(C = C + INCR)

4. con los nuevos valores hallo el area de cada una de sus caras sumo los tres valores y los multiplico por 2 para el area
NA_PLPD = 2((A * B) + (B * C) + (A * C))


2. ALGORITMO AREA CON INCREMENTO DEL PARALELEPIPEDO
Inicio
Conocer las tres medidas del paralelepípedo
Conocer el incremento en las medidas
Calcular el área del paralelepípedo
Calcular el volumen del paralelepípedo
Sumar el incremento al lado A
Sumar el incremento al lado B
Sumar el incremento al lado C
Mostrar la nueva área del paralelepípedo (con el incremento)
Fin_Algoritmo

3.DECLARACIÓN Y DE VARIABLES
Entrada: A, B, C, INCR : Real
Proceso: V_PLPD, A_PLPD, NA_PLPD : Real

4.SEUDO CÓDIGO
VAR
A, B, C, INCR, V_PLPD, A_PLPD, NA_PLPD : Real
Inicio
Escriba “LADO A DEL PARALELEPÍPEDO :” Lea A
Escriba “LADO B DEL PARALELEPÍPEDO :” Lea B
Escriba “LADO C DEL PARALELEPÍPEDO :” Lea C
Escriba “INCREMENTO PARA LAS CARAS :” Lea INCR
A_PLPD = 2((A * B) + (B * C) + (A * C))
V_PLPD= A *B *C

(A = A + INCR)
(B = B + INCR)
(C = C + INCR)

NA_PLPD = 2((A * B) + (B * C) + (A * C))


Escriba “AREA DEL PARALELEPIPEDO :” A_PLPD
Escriba “VOLUMEN DEL PARALELEPIPEDO :” V_PLPD
Escriba “AREA DEL PARALELEPIPEDO CON INCREMENTO :” NA_PLPD
8. Una empresa que fabrica recipientes esféricos, requiere de un programa que permita calcular el área y el volumen para estos.
1.ANALISIS DEL PROBLEMA: para calcular el area y volumen de los recipientes esferios de la fábrica, nos basamos en el programa que realizamos en el punto 5, para calcular el area y volumen de un cilindro.
Que me piden: calcular el area y el volumen de un cilindro
Que me dan: El radio y la altura del cilindro
Como lo hago:
- para hallar el area debo multiplicar la constante pi por 2, luego por el radio y la altura y sumarle 2 por pi por radio al cuadrado: a =( 2 * pi * r * h) +( 2 * pi * r**2 )
- para hallar el volumen multiplico la constante pi por radio al cudrado y luego por la altura: vol = pi * r**2 * h

2.Algoritmo calcular el area y el volumen de un cilindro
inicio
1. conocer el radio y la altura del cilindro
2. calcular el area
3. calcular el volumen
4. mostrar el area
5. mostrar el volumen
fin.

3. Declaracion de variables
entrada: r, h : real variables
proceso: a, vol : real variables
pi : real costante

4.programa en seudo código
programa calcular el área y volumen de un cilindro
var.
r, h, a, vol : real
cos
pi=3.1416. real

inicio
escriba “el radio del cilindro es: “ lea r
escriba “la altura del cilindro es: “ lea h
a =( 2 * pi * r * h )+ (2 * pi * r**2)
vol = pi * r**2 * h
escriba “El área del cilindro es: “, a
escriba “El volumen del cilindro es: “, vol
fin

5. prueba de escritorio:
r=5, h=4.5
a = (2 * 3.1416 * 5 * 4.5) +( 2 * 3.1416 * 5**2), a = 298.45
vol = 3.1416 * 5**2 * 4.5 , vol = 353.43
9. Elabore un programa en el que se lea una temperatura en Grados centígrados (entre -15 y 120) y se indique el equivalente en grados kelvin y Fahrenheit.
1.ANALISIS DEL PROBLEMA: crear un programa que me muestre en grados kelvin y en grados Fahrenheit, determinado numero de grados centígrados, el dato que se ingresa debe de estar entre -15 y 120.
Que me piden: mostrar en grados kelvin y grados Fahrenheit un dato ingresado en grados centígrados y que debe estar entre -15 y 120.
Que me dan: un dato expresado en grados centígrados.
Como lo hago:
1. conocer el número de grados centígrados.
2. verificar que el numero sea mayor o igual que -15 y menor o igual que 120
3. Calcular su valor en grados kelvin, tomando el valor en grados centígrados y sumándole 273: °k=°C + 273
4. Para calcularse valor en grados Fahrenheit, tomo el valor en grados centígrados lo multiplico por 1.8 y le sumo 32. °f = °c * 1.8 +32

2. algoritmo pasar grados centígrados a grados kelvin y a grados Fahrenheit.
Inicio
1. Conocer el valor en grados centígrados
2. Si es mayor o igual de -15 menor o igual que 120 entonces.
2.1 calcular su valor en grados kelvin
2.2 calcular su valor en grados Fahrenheit
2.3 mostrar grados kelvin
2.4 mostrar grados Fahrenheit
sino
2.5 mostrar: el dato fuera del rango establecido.
2.6 fin de la condición
3 fin.

3. Declaración de variables.
Entrada: gra_cen: grados centígrados, Real
Proceso: gra_kel: grados kelvin, real
gra_far: grados Fahrenheit, real.

4. programa en seudo código
programa convertir grados centígrados en kelvin y Fahrenheit
var.
gra_cen, gra_kel, gra_far : real
inicio
escriba “ingrese un valor de °C entre -15 y120: “ lea gra_cen
si gra_cen mayor o igual que -15 y menor o igual que 120
gra_kel= gra_cen +273
gra_far= gra_cen* 1.8 +32
escriba “ su equivalente en grados kelvin es: “, gra_kel
escriba “ su equivalente en Fahrenheitrenheit es: “, gra_far
si no
escriba “El valor ingresado no esta en el rango definido”
fin
fin

5.prueba de escritorio:
dado 100 grados centígrados, pasar a grados kelvin y a grados Fahrenheit.

gra_kel= gra_cen +273
gra_kel= 100 +273
gra_kel= 373

gra_far= gra_cen* 1.8 +32
gra_far= 100* 1.8 +32
gra_far= 212
10. Elabore un programa que permita obtener la conversión a dólares de una cantidad dada en pesos.
1. ANALISIS DEL PROBLEMA: Crear un programa que me arroje una cantidad en dólares si me los dan en pesos
Que me piden? Cantidad en dólares
Que me dan? Cantidad en pesos, valor del dólar
Como lo hago?
1. divido la cantidad de pesos en el valor del dólar (CANT_PES/VAL_DOL)
CANT_DOL = (CANT_PES / VAL_DOL)

2.ALGORITMO CONVERSION PESOS A DOLARES
Inicio
Conocer la cantidad en pesos
Conocer el valor del dólar en pesos
Calcular cantidad de dólares
Mostrar cantidad de dólares
Fin _ algoritmo

3.DECLARACIÓN DE VARIABLES
Entrada: CANT_PES, VAL_DOL : Real
Proceso: CANT_DOL : Real

4.SEUDO CÓDIGO
VAR
CANT_DOL, CANT_PES, VAL_DOL : Real
Inicio
Escriba “CANTIDAD EN PESOS :” Lea CANT_PES
Escriba “VALOR DEL DÓLAR :” Lea VAL_DOL
CANT_DOL = (CANT_PES / VAL_DOL)
Escriba “CANTIDAD EN DOLARES:”, CANT_DOL
11. Escriba un algoritmo que calcule el interés obtenido por una cantidad de dinero, para ello se debe ingresar por teclado: la cantidad de dinero, la tasa de interés, el tiempo en días. Tenga en cuenta que la tasa de interés es mensual
1.ANALISIS DEL PROBLEMA: Crear un programa que muestre el interés a pagar de un monto de dinero con una tasa de interés mensual durante un determinado tiempo
Que me piden? Valor del interés
Que me dan? Cantidad de dinero, tasa interés mensual, tiempo en días
Como lo hago?
1. multiplico la cantidad de dinero por la tasa de interés esto lo divido en 30 y luego este resultado multiplico por el tiempo en días
INTERES= ((CANT_DIN*(TAS_IN/100))/30)*DIAS

2.ALGORITMO INTERES A PAGAR
Inicio
Conocer cantidad de dinero, tasa de interés, tiempo en días
Calcular valor del interés
Mostrar valor del interés
Fin _ algoritmo

3. DECLARACIÓN Y DE VARIABLES
Entrada: CANT_DIN, TAS_IN, DIAS: Real
Proceso: INTERES: Real

4.SEUDO CÓDIGO
VAR
CANT_DIN, TAS_IN, DIAS, INTERES: Real

Inicio
Escriba “CANTIDAD DE DINERO:” Lea CANT_DIN
Escriba “TASA DE INTERES:” Lea TAS_IN
Escriba “TIEMPO EN DIAS:” Lea DIAS
INTERES= ((CANT_DIN*(TAS_IN/100))/30)*DIAS
Escriba “VALOR INTERES:”, INTERES
13. Se requiere un programa para calcular el valor total de los pagos hechos por una persona. Los datos por persona son: Cédula, Nombre, valor primer pago, valor segundo pago, valor tercer pago.


1. ANALISIS DEL PROBLEMA: Se requiere un programa para calcular el valor total de los pagos hechos por una persona. Los datos por persona son: Cédula, Nombre, valor primer pago, valor segundo pago, valor tercer pago.

Que me piden ¿calcular el valor total de pagos hechos por una persona
Que tengo? Cedula nombre valor 1, 2 y 3 pago
Como lo hago? Sumo los pagos efectuados (nombre, cedula Vp1 + Vp2 + Vp3 = Vt)

2 algoritmo total pagos
Inicio
Saber datos de la persona
Saber datos de los pagos
Calcular el valor total de los pagos
Mostrar el total
Fin

3 declaración de variables
Entrada nombre (N) cedula(C) constantes valor pago (Vp)>(Vp1)(Vp2)(Vp3)
Variables proceso valor total (Vt) variable

4 algoritmo en seudo lenguaje
inicio
Escriba “nombre”
Escriba “cedula”
Escriba “valor pago1” lea Vp1
Escriba “valor pago2” lea Vp2
Escriba “valor pago3” lea Vp3
Vt = Vp1 + Vp2 + Vp3
Escriba valor total “lea Vt”

14. Se ingresa tres valores por teclado se requiere obtener su media aritmética.

ANALISIS DEL PROBLEMA: diseñar un programa en el cual podamos obtener la medida aritmética de tres valores determinados
Que me piden? La media aritmética de tres valores
Que tengo? Valor1 valor2 valor3 media aritmética
Como lo hago? Clasifico los valores y realizo formulas
V/2

2 algoritmo medida aritmética
Inicio
Conocer los valores ingresados
Calcular la mitad de los valores
Mostrar el resultado
Fin

3 declaración de variables
entrada: valor1 valor2 valor3 media aritmética
Proceso: resultado

4 algoritmo en seudo lenguaje
inicio
Escriba “valor1 valor2 valor3” lea V
Vt = V1 V2 V3/2

15. Escriba un programa que le permita solucionar la siguiente formula. M + N / P - Q.
Solución del problema: diseñar un programa en el cual podamos solucionar la formula m+n/p-q
Que me piden? Solucionar la formula M+N/P-Q
Que tengo? M+N/P-Q
Como lo hago? Desarrollo la formula

2. algoritmo formula
inicio
Ingresar valores
Calcular M+N/P-Q
Mostrar resultado
Fin

3. declaración de variables
entrada M,N,P,Q
Proceso R

4 algoritmos en seudo código
inicio
Escriba “M” lea M
Escriba “N” lea N
Escriba “P” lea P
Escriba “Q” lea Q
R= M+N/P-Q
Escriba “R” lea R
16. De una distancia dada en Kilómetros se debe determinar a cuantos metros y decámetros equivale, escriba un programa.
ANALISIS DEL PROBLEMA: diseñar un programa donde podamos determinar los metros y decímetros que equivale una distancia dada en kilómetros
¿Que me piden? un programa para determinar una distancia
¿Que tengo? distancia dada en kilómetros
¿Como lo hago? dividiendo la distancia en Kilómetros en 1000 y la de Decámetros en 100
2: Algoritmo distancia en D y M
Conocer distancia en KLM
Calcular la distancia en Kilómetros, convertirla en Metros y Decametros, dividiendo la distancia en Kilómetros en 1000 y la de Decámetros en 100.
Terminar.

3declaración de variables
Entrada D_K : Real (Distancia en Kilómetros)
Proceso D_M : Real (Distancia en Metros)
D_D : Real (Distancia en Metros)

4Algoritmo en seudo código
Algoritmo Distancia en D y M
var. D_K : Real
D_M : Real
D_D : Real
Inicio
Escriba “Distancia en Kilómetros” Lea D_K
//Aquí se calcula la distancia en metros
D_M=D_K/1000
//Aquí se calcula la distancia en Decametros
D_D=D_K/100
Escriba “Distancia en metros” D_M
Escriba “Distancia en decámetros” D_D

17. Escriba un programa que permita calcular la edad que tendrá una persona en un año posterior. Para ello se ingresa el año actual, la edad de la persona y el año para el que se quiere saber que edad tendrá.

ANALISIS DEL PROBLEMA: un programa por el cual podamos calcular la edad que tendrá una persona en un año posterior a el que se encuentra actualmente
¿Que me piden? la edad que tendrá una persona en un año posterior
¿Que tengo? el año actual la edad de la persona el año posterior
¿Como lo hago?
2 Algoritmo Edad Futura
Conocer edad de a persona
Conocer el año actual
Conocer el año para el que se quiere saber que edad tendrá
Calcular el año que se quiere saber que edad tendrá, menos el año actual, este resultado se le suma a la edad de la persona y obtenemos el resultado deseado.
Mostrar resultados
Terminar
3 declaración de variables
Entrada Edad_Per: Entero (Edad persona)
Año _ sol : Entero (Año solicitado)
Año _ actual : Entero (Año actual)
Proceso Edad _ sol : Entero (Edad solicitada)

4. Algoritmo en seudo código
Algoritmo Edad Futura
var. Edad_Per: Entero
Ano _ sol : Entero
Edad _ sol : Entero
Ano _ actual : Entero
Inicio
Escriba “Edad persona” Lea Edad_Per
Escriba “Año Actual” Lea Año _ actual
Escriba “Año solicitado” Lea Año _ sol
//aquí se calcula la edad de la persona en el año solicitado
Edad _ sol=Año _ sol-Año _ actual+Edad_Per
Escriba “ Edad que tendrá la persona en el año solicitado” Edad _ sol

18.La suma de las edades de A, B y C es 69 años. La edad de A es el doble que la de B y 6 años mayor que la de C. Cuales son esas edades? Escriba un programa que automatice el proceso de cálculo.

ANALISIS DEL PROBLEMA: Crear un programa que halle tres edades teniendo en cuenta que la suma de ellas es 69 y que la menor es la mitad de la mayor y la del medio es igual a la mayor - 6
¿Que me piden? Calcular tres edades A, B, C
¿Que me dan? Resultado de la suma de las tres
¿Como lo hago?
1. Divido 75 entre 5 para la edad de B
2. Duplico la edad de B para la edad de A
2. a la edad de A le resto 6

B =75/5
A = 2 * B
C = A - 6
2. ALGORITMO XXXX
Inicio
Conocer sumatoria de las tres edades
Calcular dato de cada edad
Mostrar dato de las tres edades
Fin _ algoritmo

3. DECLARACIÓN Y DE VARIABLES
Entrada:
Proceso: A, B, C : Entero

4. SEUDO _ CÓDIGO
VAR
A, B, C : Entero
Inicio
B =75/5
A = 2 * B
C = A - 6

Escriba “EDAD DE A :”, A
Escriba “EDAD DE B :”, B
Escriba “EDAD DE C :”, C

19. Se requiere de un programa para calcular el tiempo en que se recorre en un vehículo una distancia en kilómetros, dada una velocidad constante en kilómetros por hora.

ANÁLISIS EL PROBLEMA:

Hallar el tiempo empleado por un Vehículo en el recorrido de una distancia a una velocidad constante en kilómetros por hora.

Que me piden? Tiempo Recorrido

Que me dan? Distancia recorrida y velocidad constante
Como lo hago?

1.Dividiendo la distancia entre la velocidad constante

TIEMPO = DISTA / VELOCID

2. ALGORITMO TIEMPO Recorrido

Inicio
Conocer distancia y velocidad
Calcular el tiempo Recorrido
Mostrar el tiempo
Fin Algoritmo

3. DEFINICIÓN Y DECLARACIÓN Y DE VARIABLES
Entrada: DISTA, VELOCID: Real
Proceso: TIEMPO: Real

4. SEUDO_LENGUAJE O SEUDOCÓDIGO
VAR
DISTA, VELOCID, TIEMPO: Real
Programa CALCULAR

VAR
//zona de declaración de las variables
TIEMPO, RESULTADO: Entero
Inicio
Escriba ”Digite DISTA_VELOCID:”, lea TIEMPO
// Aquí inicia proceso de cálculo
RESULTADO: ((TIEMPO=DISTA/VELOCID)
Escriba ”El resultado es: tiempo recorrido”, RESULTADO
Fin

20.Escriba un programa donde se ingrese la velocidad a que se desplaza un bote en nudos y se indique la equivalencia en kilómetros por hora (k/h). Si se sabe que un nudo equivale a 1.853 k/h.

ANALISIS DEL PROBLEMA:

Calcular a cuantos km/h equivale la velocidad en nudos de un bote
Que me piden? Kilómetros por hora
Que me dan? Velocidad en nudos
Como lo hago?
1. multiplico la velocidad en nudos por 1.853

VEL_KH = (VEL_NUD*1.853)

2. ALGORITMO

VELOCIDAD EN NUDOS
Inicio
Conocer velocidad en nudos
Calcular velocidad en kilómetros por hora
Mostrar velocidad en km/h
Fin_Algoritmo

3. DEFINICION Y DECLARACIÓN Y DE VARIABLES

Entrada: VEL_NUD : Real
Proceso: VEL_KH : Real

4. SEUDO_LENGUAJE O SEUDO_CÓDIGO

VAR
VEL_NUD, VEL_KH : Real
Inicio
Escriba “VELOCIDAD EN NUDOS :” Lea VEL_NUD
VEL_KH = (VEL_NUD*1.853)
Escriba “VELOCIDAD EN km/h :” , VEL_NUD

21.Escriba un programa para calcular el área de un rectángulo.

. Algoritmo
Area de un rectángulo
a) Conocer la base y la altura del Rectangulo
b) Calcular el area, multiplicando Base por la altura
Terminar

Definicion y declaración de variables

Entrada B : Real (Base)
A : Real (Altura)
Proceso Ar : Real (Area)

Codificar algoritmo en SEUDO_LENGUAJE

Algoritmo Area de un rectángulo
Var B : Real
A : Real
Ar : Real
Inicio
Escriba “Base” Lea B
Escriba “Altura” Lea A
//Aquí se calcula el area del rectángulo
Ar=B*A
Escriba”Areal del rectángulo” Ar



22.El área de un paralelepípedo tiene la siguiente formula A = 2((a * b) + (b * c) + (a * c)). Escriba un programa que permita calcular el área de uno, también que calcule el área resultante de duplicar el área de cada una de sus caras.

Algoritmo
IVA
a) Conocer el porcentaje del impuesto a combrar
b) Calcular el valor del IVA a Cobrar
c) Calcular el valor total a pagar en la compra
d) Mostrar resultados
Terminar

Definicion y declaración de variables

Entrada: Porc : Real (Porcentage)
Val:Vent : Real (Valor Venta)
Proceso IVA: Real (IVA)
Val_IVA : Real (Valor IVA)
Val_pago : Real ( Valor pago)

Codificar algoritmo en SEUDO_LENGUAJE

Algoritmo IVA
Var Porc : Real
Val_Vent : Real
IVA: Real
Val_IVA : Real
Val_pago : Real
Inicio
Escriba “Valor de la venta” Lea Val_Vent
Escriba “Impuesto del IVA” Lea Porc
//Aquí se calcula el valor del impuesto del IVA a cobrar
Val_IVA=Val_Venta*Porc
//Aquí se calcula el valor total a cobrar
Val_Pago=Val_Vent+Val_IVA
Escriba “IVA” Val_IVA
Escriba “Total a pagar” Val_Pago

23.Se requiere calcular el valor total que tiene que pagar por un artículo en una tienda un comprador. Sabiendo que el IVA es un impuesto que se cobra a casi todos los artículos, este dato (porcentaje de IVA) junto con el valor neto del artículo (valor antes de IVA) debe ser ingresado, realice el calculo y muestre el resultado en siguiente orden: Valor neto, Valor IVA, Total a pagar. Escriba un programa para automatizar este proceso.

Algoritmo
IVA
a) Conocer el porcentaje del impuesto a combrar
b) Calcular el valor del IVA a Cobrar
c) Calcular el valor total a pagar en la compra
d) Mostrar resultados
Terminar

Definicion y declaración de variables

Entrada: Porc : Real (Porcentage)
Val:Vent : Real (Valor Venta)
Proceso IVA: Real (IVA)
Val_IVA : Real (Valor IVA)
Val_pago : Real ( Valor pago)

Codificar algoritmo en SEUDO_LENGUAJE

Algoritmo IVA
Var Porc : Real
Val_Vent : Real
IVA: Real
Val_IVA : Real
Val_pago : Real
Inicio
Escriba “Valor de la venta” Lea Val_Vent
Escriba “Impuesto del IVA” Lea Porc
//Aquí se calcula el valor del impuesto del IVA a cobrar
Val_IVA=Val_Venta*Porc
//Aquí se calcula el valor total a cobrar
Val_Pago=Val_Vent+Val_IVA
Escriba “IVA” Val_IVA
Escriba “Total a pagar” Val_Pago

24. Teniendo en cuenta las restricciones del problema anterior, modifique el programa para que el cálculo se haga para una cantidad indicada del mismo artículo.

ANALISIS DEL PROBLEMA:

crear un programa que calcule el total de la venta de una cantidad determinada de un articulo
Que me piden? Valor del IVA, Total a pagar de la venta
Que me dan? porcentaje IVA, valor neto del producto, cantidad
Como lo hago?
1.multiplico el valor del articulo por el iva y lo multiplico por la cantidad de productos para el valor total del iva (VAL_ART*(IVA/100) )* C_AR
2. el valor neto del articulo lo multiplico por la cantidad de articulos (VAL_ART * C_AR) para el valor de todos los artículos sin IVA
2. al valor total de articulos le sumo el valor del iva para el valor total del articulo
VAL_TOT= TOT_ART + TOT_IVA

2. ALGORITMO
DETALLES DE COMPRA
Inicio
Conocer el porcentaje del IVA, el valor del articulo y la Cantidad de Articulos
Calcular el valor total del IVA y el valor total la compra Mostrar el valor neto de todos los articulos, total del iva y el total a pagar por la compra
Fin_Algoritmo

3. DEFINICION Y DECLARACIÓN Y DE VARIABLES

Entrada: IVA, VAL_ART, C_AR : Real
Proceso: TOT_IVA, TOT_ART, VAL_TOT : Real

4. SEUDO_LENGUAJE O SEUDOCÓDIGO

VAR
IVA, VAL_ART, C_AR, TOT_IVA, TOT_ART, VAL_TOT : Real
Inicio
Escriba “VALOR DEL ARTICULO :” Lea VAL_ART
Escriba “PORCENTAJE DEL IVA :” Lea IVA
Escriba “CANTIDAD DE ARTICULOS :” Lea C_ART

TOT_IVA = ((VAL_ART*(IVA/100) )* C_AR)
TOT_ART = (VAL_ART * C_AR)
VAL_TOT = TOT_IVA + TOT_ART

Escriba “VALOR NETO DE LOS ARTICULOS :” Lea TOT_ART
Escriba “VALOR TOTAL DE IVA :” Lea TOT_IVA
Escriba “VALOR TOTAL DE LA COMPRA :” Lea VAL_TOT



25.Si Velocidad es igual a V = ( d / t), donde d es distancia, t tiempo; escriba un programa que permita calcular la distancia d recorrida por un vehículo, si se sabe el tiempo t y la velocidad constante V a que se desplaza el vehículo.


ANÁLISIS DEL PROBLEMA:
calcular la distancia recorrida por u móvil durante un tiempo a una velocidad constante
Que me piden? distancia
Que me dan? Tiempo empleado, velocidad constante
Como lo hago?
1.multiplico el tiempo por la velocidad constante
DIST = TIEMPO * VELO

2. ALGORITMO
DISTANCIA RECORRIDA
Inicio
Conocer el tiempo que gastó y la velocidad constante
Calcular la distancia recorrida
Mostrar la distancia
Fin_Algoritmo

3. DEFINICION Y DECLARACIÓN Y DE VARIABLES

Entrada: TIEMPO, VELO : Real
Proceso: DIST : Real



4. SEUDO_LENGUAJE O SEUDOCÓDIGO
VAR
TIEMPO, VELO, DIST : Real
Inicio
Escriba “TIEMPO EMPLEADO :” Lea TIEMPO
Escriba “VELOCIDAD CONSTANTE :” Lea VELO

DIST = TIEMPO * VELO

Escriba “DISTANCIA RECORRIDA:” , DIST